Black Lives Matter - Action and Equality. ... Adafruit joins the Stop Hate for Profit campaign.
0

IBDAP not detected
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

IBDAP not detected

by edwardv on Fri Jul 08, 2016 12:53 pm

I recently got an IBDAP from adafruit. When I plug it in and push and release both buttons, it sometimes works to show up as a mass storage device as per the user manual. I don't know if this is relevant to my main problem, which is that when I have it plugged in, it is not recognized by my system at all and I cannot access it via openocd. I tried it on a windows computer with the same results. The openocd command I gave is "openocd -c "interface cmsis-dap" -f target/at91samdXX.cfg" This returns "Error: unable to find CMSIS-DAP device". Which makes sense, as the computer is not aware of the device. I have a SAMD20Xplained Pro, which also has a cmsis-dap device on it, which works with this same command.
I tried updating the firmware, as per the user manual, with both the provided and self-compiled firmware. I don't have any way of flashing the board directly, so I can only try to update via usb. The xplained pro board I have refuses to flash the lpc11u35 chip on the IBDAP.
I was wondering if anyone had any experience with this device who might be able to point me in the right direction.

edwardv
 
Posts: 4
Joined: Wed Feb 05, 2014 12:38 am

Re: IBDAP not detected

by edwardv on Fri Jul 08, 2016 3:11 pm

Never mind. I found a nice guide here on adafruit (here) on using a raspberry pi to flash microcontrollers using the GPIO pins. I got this to work and reflashed the IBDAP. It seems to be working. My OS is recognizing its existence at least, and that it's an IBDAP, so that's nice.

edwardv
 
Posts: 4
Joined: Wed Feb 05, 2014 12:38 am

Please be positive and constructive with your questions and comments.