0

Lines on the screen : 5.0" 40-pin 800x480 TFT Display withou
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Lines on the screen : 5.0" 40-pin 800x480 TFT Display withou

by djblex on Sun Sep 24, 2017 5:07 pm

Hello,
Following my first request “Adafruit 5 "TFT HDMI image remains superimposed in background “
Still with the super game pi project. (https://learn.adafruit.com/super-game-pi/overview)
I have another problem and hope that you will be able to help me.
It Appears 2 lines on the left (purple) and on the top (green ).
The same, i tried many settings : overscan, led framerate.. but no changement.
is there a way to remove these lines ?

Than you
Attachments
1506284397733.jpg
1506284397733.jpg (70.02 KiB) Viewed 279 times

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by adafruit2 on Mon Sep 25, 2017 11:49 am

hiya looks like you are 'forcing' audio thru HDMI - that's the audio data! try forcing audio to headphone

adafruit2
Site Admin
 
Posts: 15453
Joined: Fri Mar 11, 2005 7:36 pm

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 12:26 pm

.
Last edited by djblex on Mon Sep 25, 2017 12:30 pm, edited 1 time in total.

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 12:26 pm

Hello, thank you for your answer.
My boot config.txt has these lines as mentionned on the adafruit tutorial (https://learn.adafruit.com/super-game-pi/software)
However the sound works great on jack headphone.
Code: Select all | TOGGLE FULL SIZE
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 800 480 60 6 0 0 0
arm_freq=900
core_freq=250
sdram_freq=450
over_voltage=2
avoid_safe_mode=1
gpu_mem=256
overscan=1
Last edited by djblex on Mon Sep 25, 2017 12:38 pm, edited 6 times in total.

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 12:28 pm

is there a command line to force the headphone output ?

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by adafruit2 on Mon Sep 25, 2017 12:38 pm

sudo raspi-config

adafruit2
Site Admin
 
Posts: 15453
Joined: Fri Mar 11, 2005 7:36 pm

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 12:41 pm

i have done it from the beginning of the project :)
So it could be another problem ?

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by adafruit2 on Mon Sep 25, 2017 12:49 pm

hmm - what happens if you plug it into a 'normal' computer like windows or mac?

adafruit2
Site Admin
 
Posts: 15453
Joined: Fri Mar 11, 2005 7:36 pm

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 1:13 pm

I tried once but the screen was black, no signal, so i didn't insist.
I am going to try again but i think i need to configure Windows in screen size 800*480 to have a signal.

I come back when the test will be done.

Thank you.

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by adafruit2 on Mon Sep 25, 2017 1:25 pm

thanks, that will help us figure it out *a lot*!

adafruit2
Site Admin
 
Posts: 15453
Joined: Fri Mar 11, 2005 7:36 pm

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 5:52 pm

Hi,
So, i plugged the screen on Windows 10 but black screen : still no signal. i don't have te exactly 800X480 resolution . i tried all settings but it doesn't work.
Any idea for the colors lines ?
I have two identical screens. The lines appear on both with my RPIs..
Attachments
reslow.JPG
reslow.JPG (45.5 KiB) Viewed 194 times

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by adafruit2 on Mon Sep 25, 2017 6:21 pm

hmm if both do the same thing its probably not a hardware thing. ok can you try installing raspbian on the pi? see if that looks good?

adafruit2
Site Admin
 
Posts: 15453
Joined: Fri Mar 11, 2005 7:36 pm

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 7:02 pm

yes sure, i 'll do it tomorrow; good idea.
Thank you

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by djblex on Mon Sep 25, 2017 7:08 pm

but you don't think it can be a default production. Because they have the same date reference in back . And they do the same problem of superimposed images in background.
It was suggestion :)
Because have you seen this another problem yet?

thank you

djblex
 
Posts: 39
Joined: Sat Jul 29, 2017 3:19 am

Re: Lines on the screen : 5.0" 40-pin 800x480 TFT Display wi

by adafruit2 on Mon Sep 25, 2017 7:12 pm

this is the first time it wasnt solved by hdmi audio stuff - its really unlikely its hardware, just because we only use one chip and there's no firmware, it 'just works' :)

adafruit2
Site Admin
 
Posts: 15453
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.