0

TFT detached from the PCB of a 2.8" Capacitive TFT Shield
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

TFT detached from the PCB of a 2.8" Capacitive TFT Shield

by SolarBlight on Thu Nov 08, 2018 3:58 pm

I mounted my TFT Touch Screen to my UNO then uploaded the 'graphicstest' example, which I did not modify. The TFT just displayed a white screen. One side of the screen appears to be lifted up. I don't know if this effects it or if the TFT was like this when I first got it but I do know that the TFT worked fine before now. I have already configured the Adafruit_TFTLCD.h file for the shield. The attached photo shows how much the touch screen has lifted up on one side the PCB. I looked at it with a microscope and nothing appeared to be broken, but does this indicate that something is definitely wrong?

TFT on UNO.jpg
TFT on UNO.jpg (65.62 KiB) Viewed 71 times

SolarBlight
 
Posts: 12
Joined: Tue Sep 25, 2018 1:08 pm

Re: TFT detached from the PCB of a 2.8" Capacitive TFT Shiel

by adafruit_support_carter on Mon Nov 12, 2018 9:02 pm

That looks like the entire TFT module is lifting up slightly. If you just pressed it back down gently, does it stay put?

And I would not expect that to cause the white screen issue. Can you post some more photos showing the overall front and back of the display. Similar to the product photos.

adafruit_support_carter
 
Posts: 7014
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT detached from the PCB of a 2.8" Capacitive TFT Shiel

by SolarBlight on Tue Nov 13, 2018 1:50 pm

Pushing the TFT down on to the PCB does not keep it attached. There does not seem to be anything attaching the lifted side of the TFT to the PCB (no broken connectors, no glue remnants, etc.. ). As you can see in the photos the display still works fine, so it is not related to the white screen issue as you suggested. [additional pics in following post]


Can I just re-attach the lifted side of the TFT with a dab of epoxy or hot glue?


bmp display.jpg
bmp display.jpg (89.39 KiB) Viewed 42 times



TFT_Top.jpg
TFT_Top.jpg (180.8 KiB) Viewed 42 times



TFT_Bottom.jpg
TFT_Bottom.jpg (320.84 KiB) Viewed 42 times

SolarBlight
 
Posts: 12
Joined: Tue Sep 25, 2018 1:08 pm

Re: TFT detached from the PCB of a 2.8" Capacitive TFT Shiel

by SolarBlight on Tue Nov 13, 2018 1:52 pm

[Additional photos]

TFT_Edge1.jpg
TFT_Edge1.jpg (112.35 KiB) Viewed 42 times



TFT_Edge2.jpg
TFT_Edge2.jpg (129.03 KiB) Viewed 42 times



TFT_Edge3.jpg
TFT_Edge3.jpg (110.44 KiB) Viewed 42 times

SolarBlight
 
Posts: 12
Joined: Tue Sep 25, 2018 1:08 pm

Re: TFT detached from the PCB of a 2.8" Capacitive TFT Shiel

by SolarBlight on Tue Nov 13, 2018 1:52 pm

[Addional photo]


TFT_Edge4.jpg
TFT_Edge4.jpg (128.63 KiB) Viewed 42 times

SolarBlight
 
Posts: 12
Joined: Tue Sep 25, 2018 1:08 pm

Re: TFT detached from the PCB of a 2.8" Capacitive TFT Shiel

by adafruit_support_carter on Tue Nov 13, 2018 2:02 pm

Thanks for the excellent photos.

Can I just re-attach the lifted side of the TFT with a dab of epoxy or hot glue?

I believe so, but let me ask what's best for this product.

As you can see in the photos the display still works fine, so it is not related to the white screen issue as you suggested

I'm confused here - are you still having a white screen issue? It looks like the example sketch is running now.

adafruit_support_carter
 
Posts: 7014
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT detached from the PCB of a 2.8" Capacitive TFT Shiel

by adafruit2 on Tue Nov 13, 2018 4:51 pm

yep these are just taped on and the tape can release, just press down, put a bezel down, glue, etc :)

adafruit2
Site Admin
 
Posts: 17493
Joined: Fri Mar 11, 2005 7:36 pm

Re: TFT detached from the PCB of a 2.8" Capacitive TFT Shiel

by SolarBlight on Wed Nov 14, 2018 1:23 pm

In the photo I was using the 'spitftbitmap' routine. I get the white screen issue when I use 'graphicstest' example from the Adafruit_TFTLCD library although it seems when I use the 'graphicstest' example from the Adafruit_ILI941 library it works. Unfortunately I still get the white screen when using the mega 2560.

I will start a new post for this problem because I want to use the TFT with the mega. Thanks for the help.

SolarBlight
 
Posts: 12
Joined: Tue Sep 25, 2018 1:08 pm

Please be positive and constructive with your questions and comments.