0

HDMI 5" 800x480 screen - white screen on Raspbian+RetroPie
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by adafruit_support_mike on Mon May 13, 2019 11:21 pm

Thank you for the confirmation.

Let's see if we can approach this the other way: when you connect the display to a Windows machine where it works, can you find a control panel that tells you what settings the OS is using to talk to the display? HDMI group and mode would be ideal, but even a refresh frequency might help.

adafruit_support_mike
 
Posts: 58406
Joined: Thu Feb 11, 2010 2:51 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by quackgyver on Tue May 14, 2019 1:13 am

adafruit_support_mike wrote:Thank you for the confirmation.

Let's see if we can approach this the other way: when you connect the display to a Windows machine where it works, can you find a control panel that tells you what settings the OS is using to talk to the display? HDMI group and mode would be ideal, but even a refresh frequency might help.


I'd be happy to do that, but I wouldn't even know where to begin. Windows generally doesn't offer such debugging information in user-facing contexts, so I wouldn't know where or how to begin looking for the information that you're asking for.

quackgyver
 
Posts: 13
Joined: Mon Mar 18, 2019 3:54 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by adafruit_support_mike on Tue May 14, 2019 11:12 pm

Let me check with some of the engineers who are more familiar with Windows.. I'm the Mac and Unix geek.

adafruit_support_mike
 
Posts: 58406
Joined: Thu Feb 11, 2010 2:51 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by adafruit2 on Wed May 15, 2019 3:05 pm

hmm ok - reviewed this thread and this doesnt make any sense - raspi doesnt read the edid, you force it with config.txt ... especially if it works with windows we know it works :) so we will figure this out

have you tried plain raspbian lite? just to see if that gets it going?

adafruit2
Site Admin
 
Posts: 18586
Joined: Fri Mar 11, 2005 7:36 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by quackgyver on Sat May 18, 2019 5:35 pm

adafruit2 wrote:have you tried plain raspbian lite? just to see if that gets it going?


I've tried with both Raspbian and RetroPie.

quackgyver
 
Posts: 13
Joined: Mon Mar 18, 2019 3:54 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by adafruit2 on Sat May 18, 2019 9:48 pm

thanx - which exact version of rasbian lite?

adafruit2
Site Admin
 
Posts: 18586
Joined: Fri Mar 11, 2005 7:36 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by quackgyver on Sat May 18, 2019 9:58 pm

adafruit2 wrote:thanx - which exact version of rasbian lite?


I haven't tried Raspbian Lite. I've tried the 2018-11-13 release of Raspbian, and RetroPie 4.4.

quackgyver
 
Posts: 13
Joined: Mon Mar 18, 2019 3:54 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by adafruit2 on Sat May 18, 2019 10:18 pm

make sure you try Lite

adafruit2
Site Admin
 
Posts: 18586
Joined: Fri Mar 11, 2005 7:36 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by quackgyver on Sat May 18, 2019 10:30 pm

adafruit2 wrote:make sure you try Lite


This is going to take me several days to do.

What else can we do that is a more concrete troubleshooting step?

quackgyver
 
Posts: 13
Joined: Mon Mar 18, 2019 3:54 pm

Re: HDMI 5" 800x480 screen - white screen on Raspbian+RetroP

by adafruit2 on Sat May 18, 2019 10:55 pm

raspbian lite is what we 'know' works for sure - the only other troubleshooting step is "plug it into your computer" which you did, and works :)

adafruit2
Site Admin
 
Posts: 18586
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.