0

Ultrabright 4 watt NEOPIXEL stopped working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Ultrabright 4 watt NEOPIXEL stopped working

by jon_kessler on Tue Jun 28, 2022 4:02 pm

so I ordered 5 of these https://www.adafruit.com/product/5163 on June 9th for a project
Order #2863121-4474969773
They are Arduino controled with one of your 5V power supplies. 4 of them have been working fine, but one stopped working after a few days of usage.
I care less about the money and the replacement of the product and more about the fact that my confidence in this component is a bit shaky and I'm second guessing using them in a large project...
Any advice?

jon_kessler
 
Posts: 2
Joined: Wed Feb 18, 2015 9:48 am

Re: Ultrabright 4 watt NEOPIXEL stopped working

by dastels on Wed Jun 29, 2022 9:59 am

What's the amperage of the power supply? These should have at least a 2A supply.

Another possibility is overheating. From the product page:
Each order comes with one RGBW NeoPixel LED on an aluminum PCB/holder/heatsink. Please note that even though the PCB acts as a heatsink, 4W is a lot of power to dissipate as heat so you may need an additional heatsink or fan or other cooling mechanisms!


Dave

dastels
 
Posts: 10563
Joined: Tue Oct 20, 2015 3:22 pm

Re: Ultrabright 4 watt NEOPIXEL stopped working

by jon_kessler on Thu Jun 30, 2022 10:23 am

This is the 10 Amp power supply that I was using. Product ID: 658
Do you suggest I customize with a heat sink?

jon_kessler
 
Posts: 2
Joined: Wed Feb 18, 2015 9:48 am

Re: Ultrabright 4 watt NEOPIXEL stopped working

by dastels on Thu Jun 30, 2022 11:48 am

OK, that's more than enough current capacity.

The datasheet lists +85C as the max operating temperature. So if it's getting close to that you'll need to do something to cool it: generally a bigger heatsink and/or a fan.

Dave

dastels
 
Posts: 10563
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.