0

3.5" TFT LCD White on External Power
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

3.5" TFT LCD White on External Power

by benwingrove on Thu May 25, 2017 8:40 pm

I have a 3.5" TFT LCD hooked up to an Arduino DUE via 8-Bit
My code is running fine when I upload but if I recycle the power, either via USB or external 9v (from power supply to arduino power jack) the screen stays white until I press the reset button.

Is this because I haven't connected the RST on the screen to anything?
I hope not because I have just made up a wiring harness with only the amount of connectors I am using!!

Any suggestions?

Ben

benwingrove
 
Posts: 11
Joined: Thu Jul 14, 2016 7:32 pm

Re: 3.5" TFT LCD White on External Power

by adafruit_support_carter on Fri May 26, 2017 1:29 pm

but if I recycle the power

Provide more detail on what this means.

adafruit_support_carter
 
Posts: 2510
Joined: Tue Nov 29, 2016 2:45 pm

Re: 3.5" TFT LCD White on External Power

by benwingrove on Fri May 26, 2017 2:09 pm

Turning it off then on again

benwingrove
 
Posts: 11
Joined: Thu Jul 14, 2016 7:32 pm

Re: 3.5" TFT LCD White on External Power

by adafruit_support_carter on Fri May 26, 2017 4:08 pm

Could be a race condition. What does your code look like?

adafruit_support_carter
 
Posts: 2510
Joined: Tue Nov 29, 2016 2:45 pm

Re: 3.5" TFT LCD White on External Power

by benwingrove on Tue Jun 13, 2017 12:13 pm

Its a work in process so very long and messy!

I presume it will be something in the setup thats causing the problem, should I focus there?

benwingrove
 
Posts: 11
Joined: Thu Jul 14, 2016 7:32 pm

Re: 3.5" TFT LCD White on External Power

by adafruit_support_carter on Tue Jun 13, 2017 12:35 pm

Maybe/probably, depends on code layout. The basic idea is that the TFT display may need a little time after first power before you can talk to it. When you just plug it in via USB or 9V, everything gets power at the same time. So it might be that the DUE comes alive and starts trying to talk to the TFT before it's ready. But when you do a reset, everything stays powered, so now the TFT is ready to receive the commands and it works.

adafruit_support_carter
 
Posts: 2510
Joined: Tue Nov 29, 2016 2:45 pm

Re: 3.5" TFT LCD White on External Power

by benwingrove on Tue Jun 13, 2017 12:47 pm

I put a 500ms delay at the start of setup and that solved the problem thanks.

benwingrove
 
Posts: 11
Joined: Thu Jul 14, 2016 7:32 pm

Re: 3.5" TFT LCD White on External Power

by adafruit_support_carter on Tue Jun 13, 2017 12:52 pm

Cool. So guess that was the issue. Now you can dial that down to see how small of a delay you can get away with (or dig through datasheets in hopes of finding it speced somewhere). Or just use as is if it works for you.

adafruit_support_carter
 
Posts: 2510
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.