0

3.5" TFT 320x480 + Touchscreen Breakout Board
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

3.5" TFT 320x480 + Touchscreen Breakout Board

by dennisbowman on Tue Jun 13, 2017 2:39 pm

It doesn't seem to work! On powerup the display lights up but that’s all. I have tried SPI interface and the 8 bit Parall. and it acks the same way white screen no display. I have look at all the interface signals with a logic analyzer and all look correct?. So I guess I need to return it as it looks like a DOA one...

dennisbowman
 
Posts: 4
Joined: Tue Jun 13, 2017 2:35 pm

Re: 3.5" TFT 320x480 + Touchscreen Breakout Board

by adafruit_support_rick on Thu Jun 15, 2017 3:33 pm

Please post clear, detailed pictures of both sides of the board, showing your soldering and wiring

adafruit_support_rick
 
Posts: 34871
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: 3.5" TFT 320x480 + Touchscreen Breakout Board

by dennisbowman on Thu Jun 15, 2017 4:08 pm

Here are the pictures you ask for Connected to SPI interface.
Dennis
Attachments
0615171356a.jpg
0615171356a.jpg (691.24 KiB) Viewed 147 times
0615171356.jpg
0615171356.jpg (580.51 KiB) Viewed 147 times
0615171355.jpg
0615171355.jpg (849.78 KiB) Viewed 147 times

dennisbowman
 
Posts: 4
Joined: Tue Jun 13, 2017 2:35 pm

Re: 3.5" TFT 320x480 + Touchscreen Breakout Board

by adafruit_support_rick on Fri Jun 16, 2017 9:00 am

The IM2 jumper doesn't look like it's closed. You need the solder to actually bridge the gap

adafruit_support_rick
 
Posts: 34871
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: 3.5" TFT 320x480 + Touchscreen Breakout Board

by dennisbowman on Fri Jun 16, 2017 9:35 am

Here is a picture with im2 jumped to 3.3v !! Look as I said before I have tried both SPI and 8 bit mode and no response from display with the correct im2 jumper setting I am not sure what else I need to provide???
Attachments
0616170726.jpg
0616170726.jpg (571.54 KiB) Viewed 127 times

dennisbowman
 
Posts: 4
Joined: Tue Jun 13, 2017 2:35 pm

Re: 3.5" TFT 320x480 + Touchscreen Breakout Board

by adafruit_support_rick on Fri Jun 16, 2017 2:41 pm

Not trying to put you off, but this is almost certainly a problem with either wiring or code. What sketch are you using? Are you using one of the standard Adafruit example sketches, like graphicstest? Can you post the serial monitor output from graphicstest?

adafruit_support_rick
 
Posts: 34871
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: 3.5" TFT 320x480 + Touchscreen Breakout Board

by dennisbowman on Fri Jun 16, 2017 3:11 pm

OK Here is the picture of the Serial monitor output and the sketch and of the Display showing only a white screen when run. The sketch is from your example graphictest.
Look I have 3 other displays that I got working(SPI, 8bit & 16 bit Displays) very easy with no problems. This one has not worked at all!!! I do know how to make one WORK! I am getting tired of this Non Sense....I want to return it for a Refund because it was DOA!!!
Dennis
Attachments
2017-06-16 (1).png
2017-06-16 (1).png (17.24 KiB) Viewed 111 times
2017-06-16 (2).png
2017-06-16 (2).png (83.6 KiB) Viewed 111 times
0616171250[1].jpg
0616171250[1].jpg (484.86 KiB) Viewed 111 times

dennisbowman
 
Posts: 4
Joined: Tue Jun 13, 2017 2:35 pm

Re: 3.5" TFT 320x480 + Touchscreen Breakout Board

by adafruit_support_rick on Fri Jun 16, 2017 4:01 pm

Please email support@adafruit.com with a link to this post for a refund

adafruit_support_rick
 
Posts: 34871
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.