0

1.44" TFT not working on YUN white screen
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

1.44" TFT not working on YUN white screen

by kurtboeker on Wed Aug 02, 2017 10:02 am

Hello,

All I get is a blank white screen. Following this tutorial.
https://learn.adafruit.com/adafruit-1-4 ... g-and-test

The only warning I get is about not being able to use images because the SD library is missing.

I'm using the YUN SPI header ICSP-3 for CLK, and ICSP-4 for MOSI.

I am using tft.initR(INITR_144GREENTAB);

And I am using Option 1.
Adafruit_ST7735 tft = Adafruit_ST7735(TFT_CS, TFT_DC, TFT_RST);

Do I need to define the SPI pins 14-17?

Do I need to power the screen from the 5v SPI header? I've read shields without a 6 pin header won't work on the YUN.

Do I need to include another library specific to the YUN?

Do I need to SPI.beginTransaction?

In your tutorial MISO is not connected, although I've tried it.

This is not my first Rodeo. I've been at it about 8 hours.

I'm not going to post pictures of my soldering for you to make fun of. :) I've tested it and there's no shorts, the connections are solid, and I've looked at it with a jewelers lens. It's fine.

Thx

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by adafruit_support_carter on Wed Aug 02, 2017 1:14 pm

What example code are you running?

Do I need to define the SPI pins 14-17?

No, you are invoking with hardware SPI.

Do I need to power the screen from the 5v SPI header?

It needs 5V power from somewhere. You can use the 5V on the GPIO headers as shown in guide.

Do I need to include another library specific to the YUN?

Shouldn't for just getting the display to work.

Do I need to SPI.beginTransaction?

Not really. That should be taken care of for you in the library.

In your tutorial MISO is not connected, although I've tried it.

MISO = master in, slave out. In this case the display is the slave. It doesn't return any information, so this hook up is not needed.

I'm not going to post pictures of my soldering for you to make fun of.

Pictures would really help. I hope we've never made fun of solder jobs. If they are suspect or need improvement, we will say so though.

adafruit_support_carter
 
Posts: 2931
Joined: Tue Nov 29, 2016 2:45 pm

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Tue Aug 08, 2017 3:46 pm

Thanks very much. I managed to get it working. I had a broken wire. It works but only for about 10 seconds. Then gets all pixelated and garbled. Could this also be the connections or is the board defective. I don't mind to pay for another one. But I would like to know what the problem is.
Attachments
8-8-17-053.jpg
8-8-17-053.jpg (154.3 KiB) Viewed 169 times

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Tue Aug 08, 2017 3:48 pm

Here is it working.
Attachments
8-8-17-062.jpg
8-8-17-062.jpg (751.55 KiB) Viewed 169 times

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Tue Aug 08, 2017 3:49 pm

here it is not working. Note, I do clear the screen after each print.
Attachments
8-8-17-063.jpg
8-8-17-063.jpg (148.61 KiB) Viewed 169 times

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Tue Aug 08, 2017 3:51 pm

there is a line across the screen
Attachments
8-8-17-054.jpg
8-8-17-054.jpg (308.69 KiB) Viewed 169 times

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by adafruit_support_carter on Tue Aug 08, 2017 5:51 pm

Can't really see your solder job in that first photo, but in the other one with the working display it seems like they could be OK. But I can't see them all and the issue does look like it could be related to signal quality. Could also be on the YUN side. Go over them all and make sure they're good. You've already found one broken wire, may end up being something like a loose connection somewhere.

Just for reference, here's a guide on soldering:
https://learn.adafruit.com/adafruit-gui ... -soldering
mainly useful so you can compare yours to this:
https://learn.adafruit.com/adafruit-gui ... lder-joint

Keep trying and report back. I'm hoping it's just a wiring issue.

adafruit_support_carter
 
Posts: 2931
Joined: Tue Nov 29, 2016 2:45 pm

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Tue Aug 08, 2017 9:38 pm

Thanks. Will do

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Wed Aug 09, 2017 10:33 am

Sorry. I checked everything and the connection are fine. I'm now thinking this is a software issue because the screen keeps getting garbled at the same point, after it is redrawn 4 times blacking out the background. Or the ribbon isn't connected to the display properly. The screen was peeling off when I took it out of the box. There were a few small hair like wires coming out the front of the ribbon cable. Could this be the issue?

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by adafruit_support_carter on Wed Aug 09, 2017 10:37 am

I'm now thinking this is a software issue because the screen keeps getting garbled at the same point, after it is redrawn 4 times blacking out the background.

Post full code that you are using for this.

There were a few small hair like wires coming out the front of the ribbon cable. Could this be the issue?

Doesn't sound normal. Can you post photos of this?

adafruit_support_carter
 
Posts: 2931
Joined: Tue Nov 29, 2016 2:45 pm

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Wed Aug 09, 2017 11:21 am

I already pulled the hair like wires off. I know how to tell if it's the breakout board or not....

Order # 1513309-6212267456. Just buy another one. :)

Thanks!

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Wed Aug 09, 2017 11:35 am

Ok, it looks like I scratched one of the conductors next to the terminals. I'll let you know if the new one I just ordered works. Thx for the help.

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by adafruit_support_carter on Wed Aug 09, 2017 12:01 pm

Hey. OK. Good luck. Let me know if it works. Also, when you get the new one inspect it before using it and if you see anything like the broken ribbon cable, let us know.

adafruit_support_carter
 
Posts: 2931
Joined: Tue Nov 29, 2016 2:45 pm

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Fri Aug 11, 2017 4:46 pm

Sorry but this one is worst than the last. I'm going to replace all the wires. Worse, as in, the signal is worse. I can see a bunch of garbled pixels showing up. It redraws when I black out the screen sometimes.

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Re: 1.44" TFT not working on YUN white screen

by kurtboeker on Sat Aug 12, 2017 8:52 am

It's working PERFECT!!!! The problem was I was using a Stackable Header Kit because I'm using a case.

https://www.sparkfun.com/products/10007

I plugged the pins in directly and everything is fine. Thanks for all the help!

kurtboeker
 
Posts: 12
Joined: Wed Aug 02, 2017 9:43 am

Please be positive and constructive with your questions and comments.