0

7-Segment Display doesn't light up right
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

7-Segment Display doesn't light up right

by runesalvi1 on Tue Aug 08, 2017 8:29 am

I think this is the right subforum to post in but anyways, I have a 7-Segment Displays but 5 of the segments don't light up. Would i be right to assume this is cause by my bad soldering? If yes is there a way to find out which one to fix ?

http://i.imgur.com/rZJCGBI.jpg

runesalvi1
 
Posts: 1
Joined: Tue Aug 08, 2017 8:07 am

Re: 7-Segment Display doesn't light up right

by franklin97355 on Tue Aug 08, 2017 10:23 pm

That does not look like a solder issue but if you could post a clear picture of the soldering it would help.

franklin97355
 
Posts: 16280
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: 7-Segment Display doesn't light up right

by Waynetho on Wed Aug 09, 2017 6:01 pm

I just looked at the 0.56" display's LED module pin configuration (looks like this one, not sure if it's the right one though). There are two rows of 7 pins. Since part of the first digit is being displayed (top and upper right segments), and the other three digits are complete, it sounds like it might be a problem with the display driver chip or possibly the code being sent to the display from your program. Since the numbers are matrixed and only displayed one at a time, this would make sense. The LED driver chip is just not feeding all segments to the first digit of the display, even though it is sending them on the other three.

Waynetho
 
Posts: 16
Joined: Sat Jul 30, 2016 3:17 am

Please be positive and constructive with your questions and comments.