0

TFT 1.8" Display Not Functional
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

TFT 1.8" Display Not Functional

by jhugery on Tue Aug 08, 2017 9:46 pm

So I have the TFT 1.8" Display connected to my Arduino Uno in the following configuration:

Arduino Pin ----> TFT PIN
5V ----> VCC, Lite
Gnd ----> Gnd
9 ----> Reset
8 ----> D/C
10 ----> TFT_CS
11 ----> MOSI
13 ----> MISO

In the example Graphics test script, the following was edited

#include <Adafruit_GFX.h> // Core graphics library
#include <Adafruit_ST7735.h> // Hardware-specific library
#include <SPI.h>


// For the breakout, you can use any 2 or 3 pins
// These pins will also work for the 1.8" TFT shield
#define TFT_CS 10
#define TFT_RST 9 // you can also connect this to the Arduino reset
// in which case, set this #define pin to 0!
#define TFT_DC 8

// Option 1 (recommended): must use the hardware SPI pins
// (for UNO thats sclk = 13 and sid = 11) and pin 10 must be
// an output. This is much faster - also required if you want
// to use the microSD card (see the image drawing example)
Adafruit_ST7735 tft = Adafruit_ST7735(TFT_CS, TFT_DC, TFT_RST);

// Option 2: use any pins but a little slower!
#define TFT_SCLK 13 // set these to be whatever pins you like!
#define TFT_MOSI 11 // set these to be whatever pins you like!
//Adafruit_ST7735 tft = Adafruit_ST7735(TFT_CS, TFT_DC, TFT_MOSI, TFT_SCLK, TFT_RST);
<.....Remainder of the Script......>

Here are the photos of the connections:

conn1_800.JPG
Connection 1
conn1_800.JPG (172.74 KiB) Viewed 146 times


conn2_800.JPG
Connection 2
conn2_800.JPG (199.99 KiB) Viewed 146 times


The script compiles OK and uploads OK without error. However the display is only white.

output_800.JPG
Output
output_800.JPG (147.36 KiB) Viewed 146 times


Do I have a bad display? I made certain I am getting 5V at Lite,VCC, and on Reset 0V is on GND. Ideas?

jhugery
 
Posts: 13
Joined: Sun Aug 28, 2016 1:04 pm

Re: TFT 1.8" Display Not Functional

by adafruit_support_rick on Thu Aug 10, 2017 10:31 am

Hmmm. Wiring looks right, and soldering looks good. But I'm reluctant to simply say that the display is bad - we test everything before shipping.

Can you try some different jumpers on the data and control lines?

adafruit_support_rick
 
Posts: 34871
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: TFT 1.8" Display Not Functional

by jhugery on Sun Aug 13, 2017 6:31 pm

Just tried that. Same result. White display only...

jhugery
 
Posts: 13
Joined: Sun Aug 28, 2016 1:04 pm

Re: TFT 1.8" Display Not Functional

by adafruit_support_rick on Mon Aug 14, 2017 6:23 am

Please email support@adafruit.com with a link to this post for a replacement 1.8" TFT

adafruit_support_rick
 
Posts: 34871
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.