0

Only two of the LEDs light up
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Only two of the LEDs light up

by jneon on Fri Sep 29, 2017 3:29 pm

HI,

I'm having a problem with my LEDs. Only two of the LEDs light up of my Adafruit NeoPixel Digital RGB LED Strip: https://www.adafruit.com/product/1138 running the sample fade code from Arduino.

Thank you,
Jackie
Attachments
sad-leds.gif
sad-leds.gif (182.39 KiB) Viewed 106 times

jneon
 
Posts: 2
Joined: Thu Oct 24, 2013 12:36 pm

Re: Only two of the LEDs light up

by caitlinsdad on Fri Sep 29, 2017 9:29 pm

The example fade code from the Arduino IDE is for regular LEDs and would give unpredictable results. Neopixels are different and require a library to be installed and has the Strandtest demo program. See if you have it all set up correctly by looking in the tutorial https://learn.adafruit.com/adafruit-neo ... e/overview and running the strandtest(change the parameters in code for pin used, number of neopixels and if RGBW type). Good luck.

caitlinsdad
 
Posts: 393
Joined: Fri Feb 24, 2012 4:23 pm

Re: Only two of the LEDs light up

by jneon on Mon Oct 09, 2017 8:37 pm

Hi caitlinsdad that did not solve the problem, now none of the LEDs light up :( I tried having the LEDs stay on in the sketch and now none turn on.

jneon
 
Posts: 2
Joined: Thu Oct 24, 2013 12:36 pm

Re: Only two of the LEDs light up

by kcl1s on Mon Oct 09, 2017 9:17 pm

I can not tell where you are getting power and ground from but I assume it is 5 volts. The ground wire needs to connect to the Arduino board ground also for it to work.

If your wiring is OK the next thing to check is the code you are running. Copy and paste your complete sketch here using the code button above the text editor to make your code easier to read.

Keith

kcl1s
 
Posts: 347
Joined: Tue Aug 30, 2016 12:06 pm

Please be positive and constructive with your questions and comments.