0

Can't get 3.5" PiTFT to work - white screen
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Can't get 3.5" PiTFT to work - white screen

by vladiks on Thu Oct 12, 2017 7:59 am

Hello,

I am unable to get my 3.5" PiTFT touchscreen to work. At first I tried to make it work on custom PCB made for Pi compute board. After some time, I wanted to exclude option, that our PCB, or combination TFT with compute module, is wrong. So now I connected PiTFT to Raspberry 2 model B and the result is still the same - the screen is still all white. I can only change the backlit using GPIO pwm. I am using "Jessie Lite-based PiTFT 3.5" Resistive Image for Pi 1, Pi 2 and Pi 3 (Sept 23, 2016 image, made Nov 10)".

I attached dmesg output. I guess there is some problem in spi communication:
Code: Select all | TOGGLE FULL SIZE
[    6.710558] stmpe-spi spi0.1: unknown chip id: 0x0
[    6.710623] stmpe-spi: probe of spi0.1 failed with error -22

In the meantime, I am waiting for other display to exclude hw error...
Please advise
Attachments
dmesg.txt
(21.48 KiB) Downloaded 2 times

vladiks
 
Posts: 1
Joined: Wed Oct 11, 2017 7:55 am

Re: Can't get 3.5" PiTFT to work - white screen

by adafruit_support_rick on Thu Oct 12, 2017 12:06 pm

stmpe-spi is the touch controller chip. So it's not finding that. But it is finding fb_hx8357d, which is the display controller chip.

I wonder if your ribbon cable is loose or not seated properly. See this picture:
https://learn.adafruit.com/adafruit-pit ... faq#faq-15

If you still have problems, please post a picture of the bottom of the PiTFT.

adafruit_support_rick
 
Posts: 34764
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Please be positive and constructive with your questions and comments.