0

Help with 32x32 RGB LED Matrix
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Help with 32x32 RGB LED Matrix

by Chairmanofboxes on Mon Nov 20, 2017 2:12 am

I've been having a lot of curious difficulty with the 32x32 RGB LED Matrix (https://www.adafruit.com/product/2026). I am using an Arduino Uno and have been unable to get the example sketch (colorwheel_33x32) to run. I have the matrix powered by a 2A, 5V power supply (I've checked that the matrix is getting proper power). Additionally, I have checked and re-checked the wiring (https://imgur.com/a/3jqBF) is correct according to the tutorial (https://learn.adafruit.com/32x16-32x32- ... mper-wires).

Here is what I am getting in response when the matrix is powered and the Arduino turned on (https://imgur.com/2tQGlQ0). Two rows of LEDs are lighting up and changing colors rapidly. I'm not sure what to do about the problem. I've looked at a number of other posts with similar issues, but have not found one that contained a satisfactory fix. Is there anyone with any ideas on how to help? Thanks!
Chairmanofboxes
 
Posts: 2
Joined: Thu Jul 31, 2014 4:11 pm

Re: Help with 32x32 RGB LED Matrix

by dbuskirk on Fri Nov 24, 2017 9:18 am

This is not so much of a reply as a suggestion that this is not an isolated problem.

I received a 32x32 LED matrix on Wednesday, but my excitement faded rapidly.

I have been unable to get the 32x32 color wheel to run. Testing using the 16x32 colors and 16x32 shapes works fine; of course I only get two sets of eight rows. Curiously, when I change the latch pin from A3 to 10 I get the other two sets of eight rows to work. This leads me to believe that my connections are correct.

If I modify the code for the 32x32 color wheel test by removing the "D" argument (i.e. the A3 pin) from the RGBmatrixPanel constructor (thereby invoking the 16-rwo constructor), I see what appears to be pieces of the color wheel. This leads me to believe that the initialization of the D parameter in the 32x32 constructor is not occurring correctly. Perhaps there is a minor change in the hardware incompatible with the library.

As an aside, I have found that the 32x32 LED matrix is sensitive to power voltage, and it seems to work better around 3V than 5V.

Dan Buskirk

dbuskirk
 
Posts: 1
Joined: Wed Feb 13, 2013 2:45 pm

Re: Help with 32x32 RGB LED Matrix

by jeffgrip on Mon Nov 27, 2017 9:42 am

I am having the same problem. I'm using an Arduino Mega. I have also wired up the device as specified in the tutorial and can't get the color wheel to run.

Does anyone know if there is a POST or other self test for the matrix so that I rule it out as the problem?

I used a 5V 2A power supply although it seems to be getting some power from the Arduino. I get different LEDs lighting up with and without the power supply connected.

I'd like to know if there is some way to rule out the array as being the problem.

Thanks All.

jeffgrip
 
Posts: 1
Joined: Mon Nov 27, 2017 9:37 am

Re: Help with 32x32 RGB LED Matrix

by Chairmanofboxes on Sat Dec 09, 2017 6:10 pm

Has anyone else found a solution to this problem? I have still been unable to get the led Matrix to work. :(
Chairmanofboxes
 
Posts: 2
Joined: Thu Jul 31, 2014 4:11 pm

Please be positive and constructive with your questions and comments.