0

Neopixels strip anormal behaviour
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Neopixels strip anormal behaviour

by OldChris on Mon Jan 08, 2018 11:57 am

Hi here is my problem.

The behavior of a Neopixel led strip 1 meter 60 leds (Adafruit 2846) is not OK using the same system driving properly à ring of 60 leds built on 4 ¼ Ring 1768.
My goal is to set on, one led after the other, having only one led on. The result is ok with the ring, with the strip the led just before the one on, do not turn off but shows a week green. But the biggest problem is that after led 40 the end of the strip stays off and without delay the first led of the strip switch on.
Is the led chip of another type between led strip and led ring ?
Is it a known problem related to the length of the strip, higher noise sensitivity ?

OldChris
 
Posts: 3
Joined: Mon Jan 08, 2018 11:54 am

Re: Neopixels strip anormal behaviour

by caitlinsdad on Mon Jan 08, 2018 8:02 pm

You can post of pic of what you have to be definitely sure but it seems you may have a strip and a ring with different kinds of neopixels. A RGBW type has a yellow half moon shaped element seen on the neopixel. A regular RGB one doesn't have that additional white emitter element. That said, neopixels can be chained from the data out to the data in pin of the other but you might get unpredictable behavior if you mix the two types of neopixels. The setup parameters need to be changed in the sketch on the strip definition line from RGB to RGBW, number of pixels, etc to get things working for one kind of neopixel. It's not that many neopixels or wiring length that may be of an issue with the setup not getting enough power or inteference. The possible workaround is to have the strip run off another data pin from the arduino, declare a new instance of your strip and make your program address the second strip or ring. Good luck.

caitlinsdad
 
Posts: 544
Joined: Fri Feb 24, 2012 4:23 pm

Re: Neopixels strip anormal behaviour

by OldChris on Tue Jan 09, 2018 9:33 am

Thank you very much for the answer.

Do you know the chip ID of the RGBW neopixel ? Because i don't use an Arduino and i need to find
information about the data pattern.

Hope you get the info.
Best regards

OldChris
 
Posts: 3
Joined: Mon Jan 08, 2018 11:54 am

Re: Neopixels strip anormal behaviour

by caitlinsdad on Tue Jan 09, 2018 9:17 pm

Look at the bottom of the product page for the datasheet https://www.adafruit.com/product/2759 They come in black or white bezel, cool and warm white... And the Neopixel uberguide for more info on how to use them https://learn.adafruit.com/adafruit-neo ... -neopixels

caitlinsdad
 
Posts: 544
Joined: Fri Feb 24, 2012 4:23 pm

Re: Neopixels strip anormal behaviour

by OldChris on Thu Jan 11, 2018 10:47 am

Thank you

In the SK6812 datasheet (RGB) datas are 24 bits organized like that : G7-G0, R7-R0, B7-B0

In the SK6812RGBW datasheet datas are 32 bits organized like that :R7-R0 G7-G0, B7-B0, W7-W0

This explains the Strange behaviour and the fact only 3/4 of the strip reacts when drived with 24 bits data instead of 32 bits

This solve the problem !
,

OldChris
 
Posts: 3
Joined: Mon Jan 08, 2018 11:54 am

Please be positive and constructive with your questions and comments.