0

PiTFT 2.8" TFT for Raspberry Pip failed to Install
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

PiTFT 2.8" TFT for Raspberry Pip failed to Install

by sjmcgrew on Tue Apr 10, 2018 4:26 pm

(Raspberri Pi 3 Model B V1.2) I have updated Raspbian and tried whatever I know (very little) several times. Here is what I get:

SELECT 1-5: 3
Select rotation:
1. 90 degrees (landscape)
2. 180 degrees (portait)
3. 270 degrees (landscape)
4. 0 degrees (portait)

SELECT 1-4: 3
[PITFT] Checking init system...
Found systemd
/boot is mounted
[PITFT] System update
Checking for correct software repositories...
Updating apt indexes...
.........
Reading package lists...
.........
[PITFT] Installing Python libraries & Software...
Installing Pre-requisite Software...This may take a few minutes!
WARNING : Pip failed to install software!
pi@raspberrypi:~ $

sjmcgrew
 
Posts: 1
Joined: Tue Mar 27, 2018 9:27 pm

Re: PiTFT 2.8" TFT for Raspberry Pip failed to Install

by hren on Sat Apr 14, 2018 8:46 am

Same here.
I am using Raspbian jessie with pixel.

hren
 
Posts: 3
Joined: Sun Nov 15, 2015 4:34 pm

Re: PiTFT 2.8" TFT for Raspberry Pip failed to Install

by cjunk on Sat Apr 14, 2018 4:17 pm

same, i have no clue what to do

cjunk
 
Posts: 1
Joined: Sat Apr 14, 2018 4:16 pm

Re: PiTFT 2.8" TFT for Raspberry Pip failed to Install

by tcvik on Fri Apr 27, 2018 8:14 am

Did anyone ever figure it out? my STEM class is having the same problem. NEED HELP TO GRADUATE!!! (adafruit 2.8" display TFT) Thanks

tcvik
 
Posts: 1
Joined: Fri Apr 27, 2018 8:13 am

Re: PiTFT 2.8" TFT for Raspberry Pip failed to Install

by pburgess on Tue May 01, 2018 9:30 pm

Install script has been fixed. Can either download the new version, or to work with what you've already got, just type:
Code: Select all | TOGGLE FULL SIZE
sudo apt-get install python-dev

and then re-run the installer script.

pburgess
 
Posts: 3961
Joined: Sun Oct 26, 2008 2:29 am

Re: PiTFT 2.8" TFT for Raspberry Pip failed to Install

by individual51 on Sat Jul 28, 2018 4:23 pm

Hi, I've tried that and get:

Installing Pre-requisite Software...This may take a few minutes!
Exception:
Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
status = self.run(options, args)
File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 353, in run
wb.build(autobuilding=True)
File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
self.requirement_set.prepare_files(self.finder)
File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
ignore_dependencies=self.ignore_dependencies))
File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 620, in _prepare_file
session=self.session, hashes=hashes)
File "/usr/lib/python2.7/dist-packages/pip/download.py", line 821, in unpack_url
hashes=hashes
File "/usr/lib/python2.7/dist-packages/pip/download.py", line 659, in unpack_http_url
hashes)
File "/usr/lib/python2.7/dist-packages/pip/download.py", line 853, in _download_http_url
stream=True,
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 501, in get
return self.request('GET', url, **kwargs)
File "/usr/lib/python2.7/dist-packages/pip/download.py", line 386, in request
return super(PipSession, self).request(method, url, *args, **kwargs)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 488, in request
resp = self.send(prep, **send_kwargs)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 609, in send
r = adapter.send(request, **kwargs)
File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/adapter.py", line 47, in send
resp = super(CacheControlAdapter, self).send(request, **kw)
File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/adapters.py", line 497, in send
raise SSLError(e, request=request)
SSLError: ("bad handshake: Error([('SSL routines', 'tls_process_server_certificate', 'certificate verify failed')],)",)
WARNING : Pip failed to install software!

Any ideas greatly appreciated. I usually manage, but I'm out of my depth here.

individual51
 
Posts: 1
Joined: Fri Nov 18, 2011 7:19 pm

Re: PiTFT 2.8" TFT for Raspberry Pip failed to Install

by pburgess on Tue Jul 31, 2018 12:17 am

Try running now, see if it behaves better today. It did just work for me (albeit very slowly).

The servers hosting these packages might have occasional downtime, or there may be connectivity issues or such. Sometimes nothing else to do but try again later.

pburgess
 
Posts: 3961
Joined: Sun Oct 26, 2008 2:29 am

Please be positive and constructive with your questions and comments.