0

2.2" 18-BIT COLOR TFT LCD persistent white screen
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: 2.2" 18-BIT COLOR TFT LCD persistent white screen

by That_one_guy on Sun Sep 08, 2019 9:51 am

I had a similar issue with my display that I just received. My display (the 2.2" TFT Display
320x240 pixels in 18 bit color with a microSD breakout) would randomly display a white screen, and I would have to reset my Arduino Mega a few times or reprogram it for it to work again. It would only function for a few minutes at most after this before the screen went white again. My serial interface was still printing information so my Arduino was still running correctly. I found that connecting the RST pin of the display breakout board directly to the Arduino 3.3V rail (and leaving it connected) fixed the problem.

That_one_guy
 
Posts: 1
Joined: Sun Sep 08, 2019 9:41 am

Re: 2.2" 18-BIT COLOR TFT LCD persistent white screen

by jadeparade on Mon Nov 11, 2019 7:10 pm

I found that connecting the RST pin of the display breakout board directly to the Arduino 3.3V rail (and leaving it connected) fixed the problem.


I've been struggling with this issue for an hour and this did the trick for me. I went from RST to RST on the Metro board with this display, and now it's displaying the entire test. Thank you!

jadeparade
 
Posts: 1
Joined: Mon Jan 11, 2016 11:44 pm

Re: 2.2" 18-BIT COLOR TFT LCD persistent white screen

by adafruit_support_carter on Thu Nov 14, 2019 1:08 pm

Sounds like maybe an issue with a floating RST line? Does it also solve the issue if you wire up RST to an available GPIO and then provide that when setting up the display:
https://github.com/adafruit/Adafruit_IL ... st.ino#L28

adafruit_support_carter
 
Posts: 14428
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2.2" 18-BIT COLOR TFT LCD persistent white screen

by waltr on Sat Jan 04, 2020 11:51 pm

Interesting point about the RESET.

I recently got the 2.8" TFT breakout and did not connect the RESET line as per the Manual. Only had a white screen.
So connected the RESET and ensured my code Toogled low then held REST high and the display worked.

Since I do much electronics and pay attention to pins like RESET and the timing connecting and handling RESET timing in code makes sense.
waltr
 
Posts: 294
Joined: Wed Jun 12, 2013 5:01 pm

Please be positive and constructive with your questions and comments.