0

problem with 64x64 LED panel
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

problem with 64x64 LED panel

by avdp on Fri Dec 14, 2018 11:36 pm

I bought a 64x64 LED panel, an RGB matrix bonnet.

Running through the sample code, only half of the LEDs light up properly. There doesn't seem to be any loose connections, but if I touch the flat ribbon cable, then they all light up. I don't really understand the electrical problem - bad panel? bad cable? bad bonnet?

I've uploaded a video of the behavior:

https://youtu.be/WruJIdj_fM0
avdp
 
Posts: 6
Joined: Sat May 17, 2014 8:10 pm

Re: problem with 64x64 LED panel

by franklin97355 on Sat Dec 15, 2018 4:15 am

Can you post closeup photos of the cable connectors with the cable attached?

franklin97355
 
Posts: 19731
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: problem with 64x64 LED panel

by avdp on Sat Dec 15, 2018 3:40 pm

Here you go:
IMG_20181215_142747.jpg
IMG_20181215_142747.jpg (396.35 KiB) Viewed 64 times

IMG_20181215_142735.jpg
IMG_20181215_142735.jpg (456.26 KiB) Viewed 64 times
avdp
 
Posts: 6
Joined: Sat May 17, 2014 8:10 pm

Re: problem with 64x64 LED panel

by franklin97355 on Sat Dec 15, 2018 6:10 pm

We can try replacing the bonnet but you should also take a look at the cable to make sure it is securely crimped. Please contact support@adafruit.com with a link to this topic and they will help you in replacing the bonnet.

franklin97355
 
Posts: 19731
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: problem with 64x64 LED panel

by avdp on Sat Dec 15, 2018 6:46 pm

Well, I figured it out... I followed instructions from mickmake.com (https://www.mickmake.com/post/build-an- ... el-project) instead of your website, and he's missing the step of soldering a blob of solder on the bottom solder jumper so the middle pad is 'shorted' to 8. Once I did that, it works perfectly. Wheew! Lessons learned - read YOUR instructions, and not rely on someone else's...
avdp
 
Posts: 6
Joined: Sat May 17, 2014 8:10 pm

Re: problem with 64x64 LED panel

by jkurleto on Tue Jan 08, 2019 10:14 pm

Hi,

Related question. I am also using the RGB matrix bonnet for the Raspberry Pi to drive a 64x64 matrix. The tutorial mentions that for non-Adafruit matrixes to check the datasheet for what value to set the jumper on the bonnet. What value in the datasheet am I looking for to figure out the jumper setting? Thanks!

jkurleto
 
Posts: 1
Joined: Fri Jan 28, 2011 6:47 pm

Please be positive and constructive with your questions and comments.