0

TFT Display - 3.5" Diagonal - Blur and Vertical Lines
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by kb0mmr on Fri Jan 04, 2019 8:20 pm

Front.jpg
Front
Front.jpg (90.8 KiB) Viewed 118 times
Pi Zero hook.jpg
Pi Zero hook
Pi Zero hook.jpg (146.05 KiB) Viewed 118 times
Blur and vetical lines 1.jpg
Bad display with Blur and vertical lines
Blur and vetical lines 1.jpg (201.27 KiB) Viewed 118 times

Hi,
I am requesting a replacement NTSC/PAL (Television) TFT Display - 3.5" Diagonal PID: 913. The one I received is broken with blurring and vertical lines on the display that was purchased on Order Number : 1942044-5181935542 on December 29, 2018 and received on Jan 3 2019. I am currently using a Raspberry Pi Zero /w with retropie-4.4-rpi1_zero.img installed. I also test a another NTSC/PAL (Television) TFT Display - 3.5" Diagonal PID: 913 that was purchased on the same order number and it work fine.

Thank-you

kb0mmr
 
Posts: 4
Joined: Fri Jan 04, 2019 12:55 pm

Re: TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by adafruit_support_carter on Thu Jan 10, 2019 10:24 pm

Are you testing the second display with the same Pi? And in general, everything else the same - just swapping displays?

adafruit_support_carter
 
Posts: 8561
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by kb0mmr on Thu Jan 10, 2019 11:59 pm

Yes, Everything is the same the display was the only thing swapped. Attached a picture of the good display
Attachments
IMG_3316.jpg
Working Display
IMG_3316.jpg (389.15 KiB) Viewed 83 times

kb0mmr
 
Posts: 4
Joined: Fri Jan 04, 2019 12:55 pm

Re: TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by adafruit_support_carter on Fri Jan 11, 2019 12:31 pm

It looks like some sort of connection issue. Look for anything obvious. Crude, but maybe even try the wiggle test - wiggle the video signal wires and see if the display reacts at all. Also check the ribbon cable below. It looks OK in your photo, but sometimes they aren't well seated and/or the retaining clip isn't fully pushed in.
ribbon.jpg
ribbon.jpg (24.01 KiB) Viewed 66 times

adafruit_support_carter
 
Posts: 8561
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by kb0mmr on Sat Jan 12, 2019 12:03 am

I also thought it was a connection or grounding problem. I did perform the wiggle test on the video cable with no change. Also checked both side of the ribbon cable and verify that the ribbon cable was fully seat in and locked still no change. In my opinion the problem is located on the the display side of the ribbon cable not the CCA side.

kb0mmr
 
Posts: 4
Joined: Fri Jan 04, 2019 12:55 pm

Re: TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by adafruit_support_carter on Mon Jan 14, 2019 1:50 pm

Thanks for checking. One other quick check - what if you use the second input? Any difference?

adafruit_support_carter
 
Posts: 8561
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by kb0mmr on Tue Jan 15, 2019 10:54 pm

SIr,

Same result when using second input.

kb0mmr
 
Posts: 4
Joined: Fri Jan 04, 2019 12:55 pm

Re: TFT Display - 3.5" Diagonal - Blur and Vertical Lines

by adafruit_support_carter on Wed Jan 16, 2019 1:09 pm

OK. Thanks for checking that. Let's replace it. Send an email to support@adafruit.com with a link to this thread and they can get you a new one.

adafruit_support_carter
 
Posts: 8561
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.