0

Another white screen problem: check SPI jumper soldering!
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Another white screen problem: check SPI jumper soldering!

by ewhansen on Wed Feb 13, 2019 8:37 pm

I offer this note for the benefit of other people who may face this problem. Today I tried to bring up a 3.2” TFT LCD breakout with resistive touchscreen. Like other users I’ve read on the forums, I had the dreaded white screen problem.

I discovered, when I looked really closely at the SPI jumpers with my phone (my magnifying work light wasn't good enough), that the jumper pads were not bridged by simply heating them up and flowing solder onto them. I had two beads of solder on the pads and a gap between them. Maybe I wasn't generous enough with the solder. Problem was solved by soldering a small bit of wire across each of the joints, and the display works now.

ewhansen
 
Posts: 2
Joined: Tue Feb 12, 2019 3:18 pm

Re: Another white screen problem: check SPI jumper soldering

by sotane on Thu Feb 14, 2019 9:44 am

I often face this white screen problem. I will look at SPI jumpers... I have an automotive diagnostic scan tool https://obd2scanners.org/autel/maxisys- ... stic-tool/. It also has the same type of problem, and I am thinking to throw it in my bathroom if it does not work! It is sad that it has a white screen problem. I hope I will able to solve this problem as quickly as possible.

sotane
 
Posts: 1
Joined: Thu Feb 14, 2019 9:27 am

Please be positive and constructive with your questions and comments.