0

brand new 2.8" TFT Touch Shield not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: brand new 2.8" TFT Touch Shield not working

by adafruit_support_carter on Fri Aug 23, 2019 12:22 pm

OK, no worries. I think that is what is happening. For the MEGA, you'll likely need to cut/solder those pads.

We are looking into our documentation on this. It seems inconsistent and out of sync with the current product rev in some places.

adafruit_support_carter
 
Posts: 13003
Joined: Tue Nov 29, 2016 2:45 pm

Re: brand new 2.8" TFT Touch Shield not working

by MakerMelissa on Fri Aug 23, 2019 12:42 pm

Thanks for pointing this out. Documentation has been updated.

MakerMelissa
 
Posts: 70
Joined: Wed Jun 05, 2013 2:10 am

Re: brand new 2.8" TFT Touch Shield not working

by MakerMelissa on Fri Aug 23, 2019 8:19 pm

The board repo was out of date, but now contains the latest schematics as well.

MakerMelissa
 
Posts: 70
Joined: Wed Jun 05, 2013 2:10 am

Re: brand new 2.8" TFT Touch Shield not working

by davidsi on Mon Aug 26, 2019 10:40 pm

here you go

2019-08-26 19.33.32.jpg
2019-08-26 19.33.32.jpg (91.01 KiB) Viewed 29 times

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Re: brand new 2.8" TFT Touch Shield not working

by MakerMelissa on Mon Aug 26, 2019 10:48 pm

Thanks for providing the photo. For the Mega, you'll need to cut the traces on the pads for pins 11-13 in the lower left and bridge the ICSP ones. You can follow the preparing the board section of this page: https://learn.adafruit.com/adafruit-2-8 ... quickstart which has photos and is the same steps for the Mega.

MakerMelissa
 
Posts: 70
Joined: Wed Jun 05, 2013 2:10 am

Re: brand new 2.8" TFT Touch Shield not working

by davidsi on Tue Aug 27, 2019 12:31 am

THANK YOU

davidsi
 
Posts: 68
Joined: Tue Oct 01, 2013 8:46 pm

Please be positive and constructive with your questions and comments.