0

2.2" TFT not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

2.2" TFT not working

by ldpalmer on Wed Aug 21, 2019 10:46 pm

I'm trying to get the test code working on a new 2.2" TFT w/ILI9340C 240x320
The screen just stays white. I've tried test code on an Arduino Uno as well as CircuitPython code on a Metro M4 and a Grand Central M4.
I think it might be DOA.
Is there anything else I should try?
Thanks.

ldpalmer
 
Posts: 5
Joined: Thu Mar 22, 2018 1:10 pm

Re: 2.2" TFT not working

by dastels on Thu Sep 05, 2019 11:56 am

Which product # is the display board?

dastels
 
Posts: 219
Joined: Tue Oct 20, 2015 3:22 pm

Re: 2.2" TFT not working

by ldpalmer on Sun Sep 15, 2019 8:33 pm

2.2" 18-bit color TFT LCD display with microSD card breakout PID: 1480

ldpalmer
 
Posts: 5
Joined: Thu Mar 22, 2018 1:10 pm

Re: 2.2" TFT not working

by dastels on Mon Sep 16, 2019 10:12 am

You've double/triple checked the solder connects and wiring? You don't mention your experience/comfort level soldering, but https://learn.adafruit.com/adafruit-guide-excellent-soldering is a good introduction/refresher.

dastels
 
Posts: 219
Joined: Tue Oct 20, 2015 3:22 pm

Re: 2.2" TFT not working

by ldpalmer on Wed Sep 18, 2019 12:10 pm

I have quite a lot of soldering experience in electronics manufacturing. The connections look fine.
I've triple checked the wiring on each of the boards I've tried to test this display with.
I also have several other tft displays that all work fine.
It looks like my tft is indeed DOA.
What should I do next?
Thank you.

ldpalmer
 
Posts: 5
Joined: Thu Mar 22, 2018 1:10 pm

Re: 2.2" TFT not working

by dastels on Wed Sep 18, 2019 5:38 pm

Contact support about a replacement. The links in the page footer.

dastels
 
Posts: 219
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.