0

Neopixel Seesaw controlled stopps at LED 21
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Neopixel Seesaw controlled stopps at LED 21

by Timon11 on Fri Aug 23, 2019 11:20 am

Hello,
I have a RGBW Neopixel Strip (30LED/m) and controll it using a Seesaw and a Arduino Uno.
Between Seesaw and LED Strip is a bit of cable but at the beginning of the string I've still got 4,9Volts.

For testing I have a light running from LED 1 to the End (lights stay on). It works perfectly up to LED 21 but after that nothing.
It shouldn't be the voltage drop as there is no red shift yet and I had the whole strip glowing while fiddling with the data wire without a problem. Pixel 22 is just 0,7m away from the power connection. The guide says that up to 1m should be fine.

Do you guys have any idea why the signal suddenly stops? The Signal is reproduced after every LED correct? So Signal strength shoudn't be the problem either.

Sorry for all spelling and grammaticall errors. (Not my native language)

Timon11
 
Posts: 18
Joined: Mon Jun 03, 2019 5:04 pm

Re: Neopixel Seesaw controlled stopps at LED 21

by dastels on Thu Sep 05, 2019 11:36 am

Can you post your code? Please use the [code] button above with it all selected so that it's formatted readably.

dastels
 
Posts: 175
Joined: Tue Oct 20, 2015 3:22 pm

Re: Neopixel Seesaw controlled stopps at LED 21

by Timon11 on Thu Sep 05, 2019 12:21 pm

Thanks for the interest in this problem :)
I was able to "solve" it in another post https://forums.adafruit.com/viewtopic.php?f=8&t=152524

The problem lies with a firmware error in the Seesaw chip

Timon11
 
Posts: 18
Joined: Mon Jun 03, 2019 5:04 pm

Please be positive and constructive with your questions and comments.