0

New 64x32 4mm LED matrix from Adafruit is extremely noisy
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

New 64x32 4mm LED matrix from Adafruit is extremely noisy

by paulslocum on Sun Sep 29, 2019 9:57 am

I bought the 64x32 4mm LED panel and it is extremely noisy compared to panels I've bought from Amazon previously. And in fact, recently all panels I've bought from Amazon also have the same problem. I'm using the Adafruit Matrix Hat and I was not able to find any timing or color parameter that fixed the issue. I'm using the very short ribbon cables that came with the panels, and I've tried different cables. Using a 5V 10A power supply.

Compare the Amazon panels I bought earlier this year to the Adafruit panels I got this week:

Amazon panels I bought earlier this year with a clear picture:
https://www.youtube.com/watch?v=4Ojo11erqdQ

Adafruit panels I got this week with a huge amount of noise:
https://www.youtube.com/watch?v=zMdqvEBiD8A

Are these panels bad or is there some way to fix this? I'm using the "high quality" mode of the Matrix Hat with RPi audio disabled.

paulslocum
 
Posts: 8
Joined: Fri Sep 27, 2019 11:29 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by paulslocum on Wed Oct 02, 2019 1:20 am

After further adjustment (removing the GPU overclocking), all of the panels I bought from various vendors now work without visual noise except the ones from Adafruit. Any suggestions?

paulslocum
 
Posts: 8
Joined: Fri Sep 27, 2019 11:29 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by paulslocum on Thu Oct 03, 2019 4:03 pm

Could really use an answer here.

paulslocum
 
Posts: 8
Joined: Fri Sep 27, 2019 11:29 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by kflmiami420 on Wed Oct 09, 2019 6:00 pm

can you post pictures of your wiring setup ? what power supply are you using ?

kflmiami420
 
Posts: 111
Joined: Tue Aug 21, 2018 9:43 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by paulslocum on Wed Oct 09, 2019 6:11 pm

It's a Hub75 keyed connector and it plugs in one way, so not much notable wiring to post pictures of. I'm using the 6 inch ribbon cable it came with and I've tried a bunch of other ribbon cables. As I said, I'm using a 5V 10A power supply which works with every other panel I've tried and can power up to 4 panels with no problems. Every other Amazon LED panel I've tried works correctly, which includes a variety of models. So it doesn't seem like a wiring or power supply problem to me.

paulslocum
 
Posts: 8
Joined: Fri Sep 27, 2019 11:29 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by adafruit_support_carter on Thu Oct 10, 2019 12:00 pm

It looks like you are testing with two panels chained together.
panels.jpg
panels.jpg (47.97 KiB) Viewed 54 times

For troubleshooting, try driving just one panel.

What model Pi are you using?

adafruit_support_carter
 
Posts: 13170
Joined: Tue Nov 29, 2016 2:45 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by paulslocum on Thu Oct 10, 2019 12:04 pm

I have tested the panels many times with just one. I've tried multiple Adafruit Matrix Hats, multiple Raspberry Pis, multiple power supplies, multiple power wiring adapters, multiple ribbon cables, and always the various panels I've bought from Amazon work great and your panels have a bunch of noise. I'm using the RPi 3B.

paulslocum
 
Posts: 8
Joined: Fri Sep 27, 2019 11:29 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by adafruit_support_carter on Thu Oct 10, 2019 12:12 pm

Set everything up with a single panel and post photos showing how everything is connected together.

What is the complete command line your are running for the test?

adafruit_support_carter
 
Posts: 13170
Joined: Tue Nov 29, 2016 2:45 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by paulslocum on Thu Oct 10, 2019 12:46 pm

I'm using my own C code, but the distortion appears with all the demos as well.

Code: Select all | TOGGLE FULL SIZE
sudo ./demo -D 0 --led-gpio-mapping=adafruit-hat
Attachments
2019-10-10 09.34.29 copy.jpg
2019-10-10 09.34.29 copy.jpg (459.09 KiB) Viewed 46 times
2019-10-10 09.34.08 copy.jpg
2019-10-10 09.34.08 copy.jpg (521.15 KiB) Viewed 46 times

paulslocum
 
Posts: 8
Joined: Fri Sep 27, 2019 11:29 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by adafruit_support_carter on Thu Oct 10, 2019 1:11 pm

Thanks for the photos. That all looks good. Got the 4 to 18 jumper in place, soldering looks good, etc.

Did you install everything using the install script?
https://learn.adafruit.com/adafruit-rgb ... tware-4-16

Have you tried using --led-slowdown-gpio= when running the demo? If not, try that, and start with a value of 1, so:
Code: Select all | TOGGLE FULL SIZE
sudo ./demo -D 0 --led-gpio-mapping=adafruit-hat --led-slowdown-gpio=1

adafruit_support_carter
 
Posts: 13170
Joined: Tue Nov 29, 2016 2:45 pm

Re: New 64x32 4mm LED matrix from Adafruit is extremely nois

by paulslocum on Thu Oct 10, 2019 1:40 pm

led-slowdown-gpio value of 2 worked. The documentation of that parameter is not very clear.

Thanks for the help, but that took way took long and too many emails and thread bumps. If you're going to claim 1-2 day response to support requests then you need to at least get close to that.

paulslocum
 
Posts: 8
Joined: Fri Sep 27, 2019 11:29 pm

Please be positive and constructive with your questions and comments.