0

Running a Flora and neopixels off 2S LiPo?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Running a Flora and neopixels off 2S LiPo?

by Shadic_ on Fri Oct 04, 2019 11:13 am

So I’m working on running about 10-20 neopixels off of a Flora V3, and was planning on using the high capacity 2S LiPo battery I already have. Would it be bad to run the pixels off of the 3.3V pads? From what I can tell the pixels would work fine off of VBAT if I was using a 1S LiPo, but I think 2S would be too high voltage. Should I just use a 5V regulator between the battery and the Flora, and then use VBAT off the Flora?

Shadic_
 
Posts: 2
Joined: Thu Jan 10, 2019 10:06 pm

Re: Running a Flora and neopixels off 2S LiPo?

by franklin97355 on Fri Oct 04, 2019 2:38 pm

Check out the product description here https://www.adafruit.com/product/659 and the tutorial here https://learn.adafruit.com/getting-started-with-flora/downloads The battery input will handle batteries up to 16 volts.

franklin97355
 
Posts: 21204
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Running a Flora and neopixels off 2S LiPo?

by adafruit_support_bill on Fri Oct 04, 2019 2:47 pm

The Flora can handle that power source. But the higher the input voltage, the harder the regulator needs to work to regulate it down to 3.3v. It is not a good idea to try to run that many pixels from the 3.3v pin.

20 RGB pixels would pull 1.2A worst-case. In 'typical' applications, probably more like 400mA.

Powered by 7.4v, the regulator would need to drop 4.1v. At 400mA, that would be 1.64 watts. Well beyond the heat dissipation capacity of the regulator chip.

adafruit_support_bill
 
Posts: 74610
Joined: Sat Feb 07, 2009 10:11 am

Re: Running a Flora and neopixels off 2S LiPo?

by Shadic_ on Fri Oct 04, 2019 7:24 pm

adafruit_support_bill wrote:Powered by 7.4v, the regulator would need to drop 4.1v. At 400mA, that would be 1.64 watts. Well beyond the heat dissipation capacity of the regulator chip.

So if I put something like this: https://www.amazon.com/dp/B07DYXTX9H/ref=cm_sw_r_cp_api_i_Rg9LDbCATZQ4X work if I were to put that between the battery and the Flora, and then just ran the pixels off the VBAT pads on it?

Shadic_
 
Posts: 2
Joined: Thu Jan 10, 2019 10:06 pm

Re: Running a Flora and neopixels off 2S LiPo?

by adafruit_support_bill on Fri Oct 04, 2019 8:25 pm

Yes. That would be a good way to power the pixels. Although running the pixels at 5v, you may need to add a level shifter since the Flora control signals are 3.3v.
https://www.adafruit.com/product/1787

adafruit_support_bill
 
Posts: 74610
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.