🎁📬❄️📦Adafruit Holiday Shipping Deadlines 2019: Please place all UPS 2 Day orders by 11am Monday, December 16 📦❄️📬🎁
0

Tower light buzz ok LEDS not ok
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Tower light buzz ok LEDS not ok

by Joseyeire on Wed Nov 27, 2019 9:43 pm

Hi there,
I bought the Tower Light - Red Yellow Green Alert Light with Buzzer - 12VDC PID: 2993.

I'm hooking it up to a raspberry pi zero using the following transistor circuit and GPIO pins:

https://learn.adafruit.com/rgb-led-strips/usage

On powering up the project some of the leds came on immediately, it was only until I started my python programme that they turned off and then sequentially turned on as per the programme design.

On a subsequent power up the leds have not turned on at all and the only output that seems to work is the buzzer.

I moved the buzzer onto all the other transistors and it works on all four proving the circuit is ok.

Finally, I connected each LED to 12v and they do not light up.

Is it possible I have blown the LEDs?

Should I have used a resistor in series with each LED between Vcc (12v) and the collector?

Below are the circuit connections, my only concern is that I connected a ground pin from the pizero to the ground of the 12v supply.

12v<--->BROWN LEAD><---><RED LEAD><--->COLLECTOR1>
12v<--->BROWN LEAD><---><GREEN LEAD><--->COLLECTOR2>
12v<--->BROWN LEAD><---><YELLOW LEAD><--->COLLECTOR3>
12v<--->BROWN LEAD><---><ORANGE(BUZZER) LEAD><--->COLLECTOR4>

12v <--->buck convertor><---><PiZero>

<PiZero> <---><GPIO39(GND)><---><GND of 12V supply> < Is this Okay to do?

<PiZero> <---><GPIO5><---><Resistor><---><BASE1>
<PiZero> <---><GPIO6><---><Resistor><---><BASE2>
<PiZero> <---><GPIO13><---><Resistor><---><BASE3>
<PiZero> <---><GPIO19><---><Resistor><---><BASE4>


Thanks,

Paul

Joseyeire
 
Posts: 11
Joined: Tue Nov 03, 2015 1:59 pm

Please be positive and constructive with your questions and comments.