📬❄️📦Adafruit Holiday Shipping Deadlines 2019: Please place all UPS 3 Day orders by 11am ET Friday December 13 📬❄️📦
0

16x32 with hat: just showing green strip of lights at top
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

16x32 with hat: just showing green strip of lights at top

by incircles on Fri Nov 29, 2019 5:07 pm

Hi! I'm a novice at circuitry and I'm having issues with the 16x32 matrix on my Raspberry Pi 4. When I power it on, I see either the first two rows or the third row in green all the way across. This is true whether or not it's connected to the Pi. When I run one of the demos (e.g. sudo ./demo -t 10 -D 1 runtext.ppm), I see another row flashing green. Nothing resembling what I should be seeing. Any ideas?

incircles
 
Posts: 6
Joined: Fri Nov 29, 2019 5:04 pm

Re: 16x32 with hat: just showing green strip of lights at to

by incircles on Fri Nov 29, 2019 5:33 pm

Interestingly, the wiring seems to be so sensitive that just moving my hand in the air above the hat will cause random lines to illuminate on the LED board. Almost always a full horizontal line, though.

incircles
 
Posts: 6
Joined: Fri Nov 29, 2019 5:04 pm

Re: 16x32 with hat: just showing green strip of lights at to

by dastels on Fri Nov 29, 2019 5:41 pm

Exactly what hardware are you using (products IDs would be the most useful).

Dave

dastels
 
Posts: 920
Joined: Tue Oct 20, 2015 3:22 pm

Re: 16x32 with hat: just showing green strip of lights at to

by incircles on Sun Dec 01, 2019 10:58 am

Medium 16x32 RGB LED matrix panel[ID:420]
Adafruit RGB Matrix HAT + RTC for Raspberry Pi - Mini Kit[ID:2345]

incircles
 
Posts: 6
Joined: Fri Nov 29, 2019 5:04 pm

Re: 16x32 with hat: just showing green strip of lights at to

by dastels on Sun Dec 01, 2019 12:21 pm

One more question... how are you powering the matrix?

dastels
 
Posts: 920
Joined: Tue Oct 20, 2015 3:22 pm

Re: 16x32 with hat: just showing green strip of lights at to

by incircles on Sun Dec 01, 2019 6:04 pm

i stripped the red and black ends of the power cord and plugged them into the + and - ends of a converter, respectively, then plugged a 5v adapter into said converter.

incircles
 
Posts: 6
Joined: Fri Nov 29, 2019 5:04 pm

Re: 16x32 with hat: just showing green strip of lights at to

by dastels on Sun Dec 01, 2019 7:37 pm

What do you mean by "converter"? That matrix takes 5v, yes?

dastels
 
Posts: 920
Joined: Tue Oct 20, 2015 3:22 pm

Re: 16x32 with hat: just showing green strip of lights at to

by incircles on Mon Dec 02, 2019 2:13 pm

Here's a pic. I believe that was the recommended power supply!
Attachments
IMG_1680.JPG
IMG_1680.JPG (534.73 KiB) Viewed 39 times

incircles
 
Posts: 6
Joined: Fri Nov 29, 2019 5:04 pm

Re: 16x32 with hat: just showing green strip of lights at to

by dastels on Mon Dec 02, 2019 2:33 pm

OK, by converter you mean the barrel/screw-terminal thing.

You've double checked the polarity?

dastels
 
Posts: 920
Joined: Tue Oct 20, 2015 3:22 pm

Re: 16x32 with hat: just showing green strip of lights at to

by incircles on Mon Dec 02, 2019 3:41 pm

The polarity should be correct. I was thinking about trying to reverse it out of curiosity, but I was worried I might damage the board.

incircles
 
Posts: 6
Joined: Fri Nov 29, 2019 5:04 pm

Re: 16x32 with hat: just showing green strip of lights at to

by dastels on Mon Dec 02, 2019 4:50 pm

Best case that there is some protection onboard. I don't see schematics of the LED panel, itself, so I have no idea if that's the case. Worst case if goes poof!

One final thing. You've double & triple checked the connection between the hat & the panel? Those connectors are right way 'round? It shouldn't be possible to have them otherwise since the connectors on the boards are keyed, but if the cable isn't ...

Double check and let me know.

Dave

dastels
 
Posts: 920
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.