🎁📬❄️📦Adafruit Holiday Shipping Deadlines 2019: Please place all UPS 2 Day orders by 11am Monday, December 16 📦❄️📬🎁
0

Bad batch of neopixels? Damaged during assembly?
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Bad batch of neopixels? Damaged during assembly?

by Chrbeo on Mon Dec 02, 2019 1:03 pm

I recently had 250 neopixels installed during assembly of 25 boards. When the boards arrived some of the LEDs didn’t function correctly or didn’t work entirely (preventing the remaining LEDs in the chain from lighting up).

Here are some images detailing the damage. So far, out of 20 LEDs, 7 were damaged.

Anyone every seen anything like this? Too much heat?

Source: https://www.digikey.com/product-detail/ ... ND/5154679

Photos: https://imgur.com/a/7zAoaYQ

Chrbeo
 
Posts: 3
Joined: Thu Feb 21, 2019 4:41 pm

Re: Bad batch of neopixels? Damaged during assembly?

by Disciple on Mon Dec 02, 2019 6:02 pm

It happened at my first effort at soldering SMT DotStars. Probing with an iron scorched the package but succeeded. The hot air test cracked. I suspect it was unsealed too long and absorbed moisture. A later test with freshly unsealed DotStars in a skillet yielded 8 good results out of 10. Don't know if that's relevant, FWIW.

Hallelujah!
Disciple

Disciple
 
Posts: 710
Joined: Tue Jan 06, 2015 8:13 pm

Re: Bad batch of neopixels? Damaged during assembly?

by Chrbeo on Wed Dec 04, 2019 2:51 pm

Disciple wrote:It happened at my first effort at soldering SMT DotStars. Probing with an iron scorched the package but succeeded. The hot air test cracked. I suspect it was unsealed too long and absorbed moisture. A later test with freshly unsealed DotStars in a skillet yielded 8 good results out of 10. Don't know if that's relevant, FWIW.

Hallelujah!
Disciple


Thanks for sharing, I suspect this is the issue as well. The assembly house is trying to imply that some of the LEDs arrived damaged, but I don’t buy it as I’ve never seen it before.

2 notes are -

humidity may have been a factor, I don’t have a clear answer from them as to how long the LEDs were out of the packaging.

They ran the LEDs through the oven twice, one for the LED side, and once for the other side of the board. It’s possible the oven was too hot, or the 2nd cycle played a factor.

Would need nice if someone from adafruit could shed some light on this.

Chrbeo
 
Posts: 3
Joined: Thu Feb 21, 2019 4:41 pm

Re: Bad batch of neopixels? Damaged during assembly?

by adafruit_support_bill on Wed Dec 04, 2019 3:28 pm

In our product description for these, we indicate that they are not recommended for reflow soldering.
https://www.adafruit.com/product/1655
These raw LEDs are cut from a reel and/or might be loose. They may not suitable for pick & place + reflow. We recommend these for careful hand soldering only!


These arrive at our factory from the manufacturer in sealed packages with dessicant. Once the package is opened the clear resin lenses will absorb moisture from the air. So any reflow processing must be completed soon after the package is opened. Otherwise the residual moisture turns to steam when heated to reflow temperatures. This causes the type of damage seen in your photo.

Some have reported success in re-drying them by baking for a while at a low temperature. But we have not tested that ourselves.

adafruit_support_bill
 
Posts: 75326
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.