🎁📬❄️📦Adafruit Holiday Shipping Deadlines 2019: Please place all UPS 2 Day orders by 11am Monday, December 16 📦❄️📬🎁
0

128x32 I2C OLED not displaying
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

128x32 I2C OLED not displaying

by TDEAF on Mon Dec 02, 2019 7:06 pm

Hi. Last week i received (among other things) a 128x32 I2C OLED which today I have been trying to get working. I have soldered the 6-pin header on, wired it to my Arduino via breadboard, and tried running the example code, all as shown in the tutorial instructions. However, I cannot get the OLED to display anything. Judicious use of Serial.println statements suggest that the sketch is running and getting past the point where I should see messages/graphics, but I still don't see anything on the display. I've tried several different I2C addresses (0x3C is the default, and 0x78 and 0x7A were suggested in some old forum posts), powered the Arduino off and on, reset it, recompiled/uploaded the sketch, but all to no avail. I certainly think I have everything wired properly, as per the tutorial page, though the tutorial is a bit confusing as it sometimes says this OLED can only be used with SPI and sometimes says it can be used with I2C. (The OLED I received says it is I2C, and has the I2C SDA and SCL pins, so I've proceeded with I2C configuration. :-))

TDEAF
 
Posts: 22
Joined: Mon Nov 25, 2019 11:19 pm

Re: 128x32 I2C OLED not displaying

by dastels on Mon Dec 02, 2019 11:01 pm

These displays don't work well (or at all) unless you make use of the reset pin. The new ones with the stemma connectors auto-reset, but older ones have to be done in your code.

Dave

dastels
 
Posts: 931
Joined: Tue Oct 20, 2015 3:22 pm

Re: 128x32 I2C OLED not displaying

by TDEAF on Tue Dec 03, 2019 8:00 am

Is there an example of what I have to do in my code? I'm happy to do that, if I know what I have to do.

TDEAF
 
Posts: 22
Joined: Mon Nov 25, 2019 11:19 pm

Re: 128x32 I2C OLED not displaying

by dastels on Tue Dec 03, 2019 11:08 am

See https://learn.adafruit.com/monochrome-oled-breakouts/arduino-library-and-examples. There's an example that got installed with the library.

Dave

dastels
 
Posts: 931
Joined: Tue Oct 20, 2015 3:22 pm

Re: 128x32 I2C OLED not displaying

by TDEAF on Tue Dec 03, 2019 11:23 am

Yes, I'm using that example and it doesn't work. And it doesn't show anything special about using the reset pin from within my code, other than where it is used when calling the constructor. This is why I reached out to this forum. :-)

TDEAF
 
Posts: 22
Joined: Mon Nov 25, 2019 11:19 pm

Re: 128x32 I2C OLED not displaying

by dastels on Tue Dec 03, 2019 2:05 pm

Let's see the solder joints where you added the header.

dastels
 
Posts: 931
Joined: Tue Oct 20, 2015 3:22 pm

Re: 128x32 I2C OLED not displaying

by TDEAF on Tue Dec 03, 2019 4:38 pm

Not a very good picture, but here one is. I suppose something could have happened with the soldering, as I'm not an expert at soldering, but all my connections have worked well on everything else I've been doing.. :-).

2019-12-03 13.12.57-1.jpg
2019-12-03 13.12.57-1.jpg (282.83 KiB) Viewed 63 times

TDEAF
 
Posts: 22
Joined: Mon Nov 25, 2019 11:19 pm

Re: 128x32 I2C OLED not displaying

by dastels on Tue Dec 03, 2019 6:29 pm

I don't see anything obviously wrong with your soldering.

You've double and triple checked the wiring between the arduino and the breakout? Everything agrees with what's used in the code?

Dave

dastels
 
Posts: 931
Joined: Tue Oct 20, 2015 3:22 pm

Re: 128x32 I2C OLED not displaying

by TDEAF on Tue Dec 03, 2019 6:40 pm

Thanks for looking. :-)

Yes and yes. I am using the example code as is from "Examples" in the Arduino IDE. And have double and triple-checked the wiring diagrams in the tutorial, have tried different UNO boards, different USB cables, different connection wires... I'm baffled.

Do you know how to raise the attention of an Adafruit support person? (My apologies if you are, but it looked like another person's ID was listed as the Adafruit moderator for this area.)

TDEAF
 
Posts: 22
Joined: Mon Nov 25, 2019 11:19 pm

Re: 128x32 I2C OLED not displaying

by dastels on Tue Dec 03, 2019 8:16 pm

It sounds like a bad board. You already have the attention required. :)

Please email support@adafruit.com with a link to this thread, your order number, and request a replacement "Monochrome 128x32 I2C OLED graphic display".

Dave

dastels
 
Posts: 931
Joined: Tue Oct 20, 2015 3:22 pm

Re: 128x32 I2C OLED not displaying

by TDEAF on Tue Dec 03, 2019 9:09 pm

OK. Will do. Thanks very much for you time and efforts to try to get this resolved.

TDEAF
 
Posts: 22
Joined: Mon Nov 25, 2019 11:19 pm

Re: 128x32 I2C OLED not displaying

by dastels on Tue Dec 03, 2019 9:22 pm

No worries. I hope the replacement works without hassle. It should, they're pretty reliable.

dastels
 
Posts: 931
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.