📬❄️📦Adafruit Holiday Shipping Deadlines 2019: Please place all UPS 3 Day orders by 11am ET Friday December 13 📬❄️📦
0

32x32 RGB LED Matrix power problems
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

32x32 RGB LED Matrix power problems

by Domerpig on Tue Dec 03, 2019 2:31 pm

I bought a Metro m4 Express Airlift together with a LED matrix and the matrix shield. I soldered everthing togehter and tried to run the colorwheel test code. For the few seconds everything was fine and then the blue LEDs were only shining very dark. Every time I reconnected the arduino with my pc it was pretty much the same result. But the longer it was disconnected the longer everything worked fine. When pressing the reset button it immediatly dimmed down.
When I tried connecting over the normal power connection the LEDs that are supposed to be on are blinking like crazy.
I'm guessing I messed up some of the soldering as I'm pretty new with this, but I don't know exactly where.
https://imgur.com/a/p3kNoR5

Domerpig
 
Posts: 1
Joined: Tue Dec 03, 2019 2:09 pm

Re: 32x32 RGB LED Matrix power problems

by dastels on Tue Dec 03, 2019 4:07 pm

Some of the soldering does look a bit inconsistent. Have a read over https://learn.adafruit.com/adafruit-guide-excellent-soldering and go over it again and see if that helps.

If things don't work as expected, I'll generally go over the soldering again without even bothering to check it. That fixes it in many cases.

Dave

dastels
 
Posts: 920
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.