Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

Conflicting info MONOCHROME 1.3"
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Conflicting info MONOCHROME 1.3"

by ImSebastian on Wed Dec 18, 2019 7:41 pm

Hey folks-

Recently I purchased a batch of p/n 938 - MONOCHROME 1.3" 128X64 OLED GRAPHIC DISPLAY. I make a product that has used this display since before it was re-released with the Stemma QT connectors soldered on.

The old version of this product (without the Stemma connectors) has a silkscreen reading "For I2C close SJ1 and SJ2" and has the pads open. The new version (with Stemma connector) has the silkscreen "Bus default is I2C, for SPI close J1/J2" and has the pads already closed...... however on the product page it says "To convert to SPI mode you will need to cut two jumpers."

I've already soldered two of these to my PCB that uses SPI, along with a host of other components. Can you please clarify which method I should follow if I want to use SPI? I fear these two displays and their PCBs might end up in the PCB boneyard...

See attached photo showing old (top) and new (bottom) LCDs.

Thank you kindly-
Sebastian
Attachments
IMG_20191218_132106.jpg
IMG_20191218_132106.jpg (784.83 KiB) Viewed 132 times

ImSebastian
 
Posts: 14
Joined: Mon Feb 09, 2015 3:43 pm

Re: Conflicting info MONOCHROME 1.3"

by ImSebastian on Wed Dec 25, 2019 3:03 pm

Happy Holidays!

At this point I can confirm that the silkscreen on your product is incorrect. The silkscreen should read: "Bus default is I2C, for SPI OPEN J1/J2" I used an extra board (not soldered to my project PCB) and I OPENED the traces, and the LCD was functional with my project that uses SPI. Your previous LCDs defaulted to SPI, your new boards do not.

So, now I'm out two of your LCDs, two JLCPCBs, two sets of SMD components, two sets of connectors, and two rotary encoders.

I've been very patient awaiting a reply, is there any input you can provide? This has significantly delayed a deliverable to a customer and I've incurred expenses (and time) with this error.

ImSebastian
 
Posts: 14
Joined: Mon Feb 09, 2015 3:43 pm

Re: Conflicting info MONOCHROME 1.3"

by ImSebastian on Mon Jan 06, 2020 2:33 am

Hey folks-

I emailed Adafruit and they told me to post here. I post here and I get nothing from the support team.

Do you have any input?

ImSebastian
 
Posts: 14
Joined: Mon Feb 09, 2015 3:43 pm

Re: Conflicting info MONOCHROME 1.3"

by adafruit2 on Mon Jan 06, 2020 1:04 pm

hi - yes there's a typo. must have happened during the transition to the stemma connector. cut open the jumpers instead of soldering them. we'll revise the silkscreen on the next time we order PCBs, thanks for the warning - we'll update the guide page :)

adafruit2
Site Admin
 
Posts: 19270
Joined: Fri Mar 11, 2005 7:36 pm

Re: Conflicting info MONOCHROME 1.3"

by ImSebastian on Mon Jan 06, 2020 1:21 pm

I appreciate you fixing this on your website and acknowledging the typo, but your error still leaves me with two of your products that are now unusable - because of this I have incurred other personal expenses (components and PCBs lost because they're soldered to the bad LCD).

At the very least I expect replacement LCDs. You changed the design of the product from the older one, and your information on the product is wrong and confusing.

Sebastian

ImSebastian
 
Posts: 14
Joined: Mon Feb 09, 2015 3:43 pm

Re: Conflicting info MONOCHROME 1.3"

by adafruit2 on Mon Jan 06, 2020 1:23 pm

sure, if you cant use the oleds, email support@adafruit.com and ask for 2 more OLEDs

adafruit2
Site Admin
 
Posts: 19270
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.