Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

3.5" HXD8357D -- White after ~10sec on Mega with longer wire
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

3.5" HXD8357D -- White after ~10sec on Mega with longer wire

by squagle on Wed Jan 08, 2020 2:04 pm

I have multiple examples of a 3.5" HXD8357D connected over SPI to a Arduino Mega where the screen goes white after about 10 seconds. The screens are running the Adafruit graphicstest demo code. I suspect the issue is power stability or wire length. The SPI, 5v & GND wires are all of the same length and about 1ft 6in long.

This display is the only device effected by these longer wires and I assume it is because it is most sensitive to (assumed) power issues.

Is there a suggested value for a decoupling capacitor between the VIN and GND pin to be added at the screen? Should any other items/changes be made due to the longer ( 1'-6" ) wire run?

Thanks for spending the time to read and comment on my question.

squagle
 
Posts: 2
Joined: Thu May 30, 2019 9:58 am

Re: 3.5" HXD8357D -- White after ~10sec on Mega with longer

by squagle on Fri Jan 10, 2020 5:46 pm

Went through various sizes of capacitors and was unable to resolve the issue. Starting to think maybe it is related to the wires flexing or bending causing the kind of issue. Going to hook up an oscope tomorrow to see if the bending of the wires is causing weird power fluctuation at the screen.

squagle
 
Posts: 2
Joined: Thu May 30, 2019 9:58 am

Please be positive and constructive with your questions and comments.