Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

NeoPixel strip are flashing after "white" led
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

NeoPixel strip are flashing after "white" led

by Glex on Mon Jan 13, 2020 6:47 am

Hello everybody,
I have problem with Led RGB neopixel strip (WS2812B chip). I'm using 45 leds and I'm controlling it by Arduino Nano. Power supply is USB charger 5V/3A ( 45 x 60mA = 2,7A ). Led strip and Arduino have same ground from USB charger.
If I use any arduino script (lib: FastLED, or NeoPixel) for animation on script, 'all' working good. Good is all single color and low brightness color. If is high brightness or white color (255, 255, 255) all strip flashing with random color in random pattern.

I try study and testing it and I find out:
I testing only 3 diods. Differend color on all diods work good, but if I set (255, 255, 255) on first diod -> first was white and second and thirs are random flashing ..... If I set on first diod only one color (255, 0, 0) or low grightness color (32, 54, 10) and on second diod I set white color -> first and second diods was good, and third diod flashing (sometimes flashing with correct color, sometime random color).
If I using for supply 3 diods only Arduino (without USB charger) all work good. But all strip can't supply by arduino.

My knowledge is: all diods after one high brightness are flashing.
And I think, It look as bad grounding, but I don't know why.

If somebody can help me I will very happy.
Thanks

Glex
 
Posts: 3
Joined: Mon Jan 13, 2020 6:11 am

Re: NeoPixel strip are flashing after "white" led

by adafruit_support_carter on Wed Jan 15, 2020 12:34 pm

Post a photo of your setup showing how everything is connected.

adafruit_support_carter
 
Posts: 16938
Joined: Tue Nov 29, 2016 2:45 pm

Re: NeoPixel strip are flashing after "white" led

by Glex on Fri Jan 17, 2020 4:22 am

I try connect supply on both sides, no results.

If I powered it by arduino all worked good, if with exrnal supply come in my problem with flashing
Attachments
Screenshot_1.jpg
Screenshot_1.jpg (152.14 KiB) Viewed 60 times

Glex
 
Posts: 3
Joined: Mon Jan 13, 2020 6:11 am

Re: NeoPixel strip are flashing after "white" led

by adafruit_support_carter on Fri Jan 17, 2020 6:54 pm

For the external power supply setup, have you verified the power supply and Arduino GNDs are connected. Do so via a continuity check from one end of your strip to another.

adafruit_support_carter
 
Posts: 16938
Joined: Tue Nov 29, 2016 2:45 pm

Re: NeoPixel strip are flashing after "white" led

by Glex on Mon Jan 20, 2020 3:57 pm

Power supply is good, I used branded USB charger, it really giving 5,2V and 3A (If it charging phone). Arduino GNDs is too connected. All strip have resistance 0,1 Ohm on GND line, It good.

It really look as not connected GND, but it is good connected

Glex
 
Posts: 3
Joined: Mon Jan 13, 2020 6:11 am

Re: NeoPixel strip are flashing after "white" led

by adafruit_support_carter on Tue Jan 21, 2020 1:45 pm

See here for info on powering NeoPixels:
https://learn.adafruit.com/adafruit-neo ... -neopixels

Since it's working with one setup, but not another, it seems like it is something with wiring.

adafruit_support_carter
 
Posts: 16938
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.