Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Adafruit PiTft 3.5" - CLI working but not GUI
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Adafruit PiTft 3.5" - CLI working but not GUI

by Drako123 on Tue Jun 23, 2020 5:30 pm

Hi,

my 3.5" PiTft touch screen for raspberry pi works fine when I use the CLI on my screen, and it shows up on my monitor when I use GUI but not on the screen. the weird thing is that if i press on the touch screen which is showing a black screen, the mouse pointer on my monitor moves to that position! it just doesn't show anything on my screen. Any hints on how I might be able to fix this issue?(couldn't find anything that fixed my problem in the forums or online)

I am using Raspbian (fully updated and upgraded). I can also ssh & vnc connect to the pi but i would actually like the screen to work if possible.

Drako123
 
Posts: 6
Joined: Sat Jan 25, 2020 10:46 pm

Re: Adafruit PiTft 3.5" - CLI working but not GUI

by BRoad on Wed Jun 24, 2020 2:18 pm

I seem to be running into this same issue... I'm trying to get my screen to work with OctoPrint (buster)/OctoDash, but the touch controls seem to be rotated separately from the display. I can't figure out how to change the rotation of the touchscreen controls. I can't get into the GUI either to configure the controls as mentioned in the instructions.

I've followed the directions to install and setup the screen. When running apt-get install evtest tslib libts-bin I get the following:

pi@octopi:~ $ sudo apt-get install evtest tslib libts-bin
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package tslib

I have not been able to get the tslib packages to install. I think this may be why the GUI isn't working, but I'm not sure. Searching the git shows that this was fixed, but it doesn't seem to be fixed.

BRoad
 
Posts: 2
Joined: Wed Jun 24, 2020 2:12 pm

Re: Adafruit PiTft 3.5" - CLI working but not GUI

by hwdornbush on Thu Aug 13, 2020 7:49 pm

My screen is working as I am using PiGate RMS which includes support for this screen. However, I would like to calibrate the touchscreen. I am following
https://learn.adafruit.com/adafruit-pit ... -calibrate

When I try
$
Code: Select all | TOGGLE FULL SIZE
sudo apt-get install evtest tslib libts-bin


I get the same error:
Code: Select all | TOGGLE FULL SIZE
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package tslib

hwdornbush
 
Posts: 5
Joined: Tue Mar 21, 2017 5:30 pm

Re: Adafruit PiTft 3.5" - CLI working but not GUI

by adafruit_support_carter on Thu Aug 13, 2020 8:17 pm

@BRoad @hwdornbush Please start new threads for your issue.

@Drako123 Sorry for delayed response. Did you re-run the install script and select the mirror HDMI option?

adafruit_support_carter
 
Posts: 16922
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.