Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

64x32 LED matrix issue
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

64x32 LED matrix issue

by mgaruccio on Thu Aug 13, 2020 9:24 am

I purchased a 64x32 LED matrix and have it wired using the matrix shield to an M4 Metro and I'm having some issues getting it to work. When using the test program the display flickers quite a bit and seems to be overlapping the text from the first and second lines together, and doing the same with the third and forth. somewhat hard to capture in pictures but I attempted to below. a video may be better but not sure the best way to share that here.
Attachments
IMG_0312.jpg
IMG_0312.jpg (937.63 KiB) Viewed 94 times

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mikeysklar on Thu Aug 13, 2020 10:06 am

I think this photo is good enough for describing the display. Thank you for providing it.

What size power supply are you using to power this? Is it a 5V @ 10A?

mikeysklar
 
Posts: 1677
Joined: Mon Aug 01, 2016 8:10 pm

Re: 64x32 LED matrix issue

by mgaruccio on Thu Aug 13, 2020 10:12 am

Ok sounds good, I'm using the 5V 4A supply suggested here - https://learn.adafruit.com/stream-deck- ... dafruit-io

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mikeysklar on Thu Aug 13, 2020 12:29 pm

Thank mgaruccio,

Since this is mostly plug and play maybe you can send me two photos of the RGB matrix shield top and bottom on it's own.

I'm particularly interested in seeing your soldering, CLK jumper cut and A4 wire connection as those seem like the only hardware issues that could have gone awry.

https://learn.adafruit.com/32x16-32x32- ... rix-shield

mikeysklar
 
Posts: 1677
Joined: Mon Aug 01, 2016 8:10 pm

Re: 64x32 LED matrix issue

by mgaruccio on Thu Aug 13, 2020 10:36 pm

Sounds good, pics of both sides of the shield attached. Also ran a continuity test between both size of the cut pad CLK and confirmed there was no conductivity between the two points.
Attachments
download (2).png
download (2).png (72.29 KiB) Viewed 87 times
download.png
download.png (76.04 KiB) Viewed 87 times

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mikeysklar on Fri Aug 14, 2020 12:51 pm

Could you post these photos at 800x600. I cannot make out any details at this resolution.

mikeysklar
 
Posts: 1677
Joined: Mon Aug 01, 2016 8:10 pm

Re: 64x32 LED matrix issue

by mgaruccio on Fri Aug 14, 2020 1:52 pm

Sorry about that, better quality pics below, let me know if you need me to try again.
Attachments
IMG_0315.jpg
IMG_0315.jpg (955.44 KiB) Viewed 81 times
IMG_0313.jpg
IMG_0313.jpg (917.51 KiB) Viewed 81 times

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mikeysklar on Fri Aug 14, 2020 2:07 pm

Okay, this soldering looks reasonable and the solder wire is in the correct position. It looks like you cut the jumper.

Did you change the CLK from 8 --> A4 in the code? Any other changes to your code?

Are you seeing this behavior on the other test patterns?

Are you running the latest libraries off github or download through the Arduino library manager?

https://github.com/adafruit/RGB-matrix-Panel
https://github.com/adafruit/Adafruit-GFX-Library
https://github.com/adafruit/Adafruit_BusIO

mikeysklar
 
Posts: 1677
Joined: Mon Aug 01, 2016 8:10 pm

Re: 64x32 LED matrix issue

by mgaruccio on Fri Aug 14, 2020 2:17 pm

I did make sure to make the change for CLK from 8 to A4. No other changes in the code. I haven't tried any other test patterns but happy to give another one a shot if there are other patterns compatible with the board. And I've been running with the libraries downloaded from the library manager.

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mikeysklar on Tue Aug 18, 2020 2:25 pm

Here are a few things to try.

Some of the solder points look like they might need a dab more heat to flow better. Could you just retouch each solder point that looks a little light or uneven with your iron to get a smoother flow that covers the pad completely. I know you have already done some continuity tests to verify a connection.

This is the only code example for the message panel that we currently have.

Do you mind upgrading the libraries using the github link I've provided. It would be nice to rule out any faulty soldering connections and dated library issues. Based on how things mostly are working I'm guessing this is a soldering / noise issue.

mikeysklar
 
Posts: 1677
Joined: Mon Aug 01, 2016 8:10 pm

Re: 64x32 LED matrix issue

by mgaruccio on Sat Aug 22, 2020 12:06 pm

I updated the to the latest versions of the library from Github and re worked every joint that looked like it was light or uneven but still the same result. photos of the updated soldering job attached from as many angles as possible in this post and the one below.
Attachments
IMG_20200822_114031.jpg
IMG_20200822_114031.jpg (307.28 KiB) Viewed 57 times
IMG_20200822_114018.jpg
IMG_20200822_114018.jpg (321.84 KiB) Viewed 57 times
IMG_20200822_114008.jpg
IMG_20200822_114008.jpg (428.63 KiB) Viewed 57 times

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mgaruccio on Sat Aug 22, 2020 12:07 pm

more photos
Attachments
IMG_20200822_114058.jpg
IMG_20200822_114058.jpg (616.69 KiB) Viewed 57 times
IMG_20200822_114050.jpg
IMG_20200822_114050.jpg (625.82 KiB) Viewed 57 times
IMG_20200822_114040.jpg
IMG_20200822_114040.jpg (403.3 KiB) Viewed 57 times

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mikeysklar on Mon Aug 24, 2020 4:04 pm

Thank you for the high quality photos. Those are always helpful.

The IDC cable you are using is there anything unusual about it? Since you are getting output and (although distorted) this really feels like a connection issue.

Do you see the same issue when trying the testshapes_32x32 or testshapes_16x32 code examples (Yes, I realize you have the 64x32).

mikeysklar
 
Posts: 1677
Joined: Mon Aug 01, 2016 8:10 pm

Re: 64x32 LED matrix issue

by mgaruccio on Mon Aug 24, 2020 4:50 pm

I've actually tried 2 different IDC cables at this point, both the one that came with the matrix (which doesn't seem to be damaged in any way) and another one sourced from Amazon just to rule that out as an issue so I don't think the issue is there. I didn't realize the other testshape patterns would work at all, I'll give those a shot tonight to see if there is any change using one of those.

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Re: 64x32 LED matrix issue

by mgaruccio on Wed Aug 26, 2020 11:30 pm

Sorry for the delayed reply but I tried both other size patterns and got effectively the same result on both, garbled text that seems to be overlapping with itself.

mgaruccio
 
Posts: 16
Joined: Sat Aug 08, 2020 9:50 pm

Please be positive and constructive with your questions and comments.