Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

7 segment 1.2" LED Brightness
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: 7 segment 1.2" LED Brightness

by XRAD on Thu Aug 20, 2020 7:59 pm

These segments are much brighter than you show when working. But, it could be the voltage regulator on the metro. Do you have a volt meter to test the 5v pin?

XRAD
 
Posts: 591
Joined: Sat Nov 19, 2016 3:28 pm

Re: 7 segment 1.2" LED Brightness

by adafruit_support_carter on Fri Aug 21, 2020 12:33 pm

The fact that you are seeing a change in apparent brightness depending on the number of segments being lit does seem to indicate some kind of power issue. Other things to check are the wires being used and the soldering on the header pins. And soldering in general, so check the matrix pins as well.

adafruit_support_carter
 
Posts: 17112
Joined: Tue Nov 29, 2016 2:45 pm

Re: 7 segment 1.2" LED Brightness

by bmwflyboy on Sat Aug 22, 2020 10:53 am

I put a meter to the 5v line coming out of the metro. On a 9v power supply it was showing 4.98v. I plugged the board into a wall wart 5v @ 2A power supply and the meter showed 4.88v. I think the soldering looks good. I attached photos in case better trained eyes might see something I am not.
Attachments
IMG_20200822_083443358.jpg
IMG_20200822_083443358.jpg (821.22 KiB) Viewed 9 times
IMG_20200822_083438699.jpg
IMG_20200822_083438699.jpg (869.48 KiB) Viewed 9 times
IMG_20200822_083434362.jpg
IMG_20200822_083434362.jpg (905.82 KiB) Viewed 9 times

bmwflyboy
 
Posts: 15
Joined: Wed Dec 07, 2016 1:27 pm

Re: 7 segment 1.2" LED Brightness

by bmwflyboy on Sat Aug 22, 2020 10:54 am

Additional photos.
Attachments
IMG_20200822_083753741.jpg
IMG_20200822_083753741.jpg (770.66 KiB) Viewed 9 times
IMG_20200822_083449516.jpg
IMG_20200822_083449516.jpg (757.64 KiB) Viewed 9 times

bmwflyboy
 
Posts: 15
Joined: Wed Dec 07, 2016 1:27 pm

Re: 7 segment 1.2" LED Brightness

by adafruit_support_carter on Mon Aug 24, 2020 12:01 pm

Thanks for the photos. That power supply should be more than adequate. There are a few pins that look possibly cold soldered and not wetted out enough on the pads. See here:
https://learn.adafruit.com/adafruit-gui ... n-problems

Check all the pins and try reflowing any that may need it with your soldering iron.

adafruit_support_carter
 
Posts: 17112
Joined: Tue Nov 29, 2016 2:45 pm

Re: 7 segment 1.2" LED Brightness

by bmwflyboy on Mon Aug 24, 2020 1:29 pm

I will check/re-do some and report back at some point. Thank you.

bmwflyboy
 
Posts: 15
Joined: Wed Dec 07, 2016 1:27 pm

Re: 7 segment 1.2" LED Brightness

by bmwflyboy on Fri Aug 28, 2020 10:53 am

I was redoing the soldering and stupidly wiped the contacts with a moist rag while it was powered up. It shorted the board out. I ordered a new one. We'll see how that goes.

bmwflyboy
 
Posts: 15
Joined: Wed Dec 07, 2016 1:27 pm

Please be positive and constructive with your questions and comments.