Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

NeoTrellisM4 board’s LEDs are not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

NeoTrellisM4 board’s LEDs are not working

by ca5 on Wed Aug 26, 2020 9:26 pm

I tried to run CircuitPython 4.x, 5.x and 6.x.
I ran following source in all 3 environments, but only 6 LEDs were working.

Code: Select all | TOGGLE FULL SIZE
import adafruit_trellism4
trellis = adafruit_trellism4.TrellisM4Express(rotation=90)
trellis.pixels.fill((0, 100, 100))


IMG_5388.jpg
IMG_5388.jpg (115.29 KiB) Viewed 20 times


Next, tried to run folowing sample program.
All push buttons were working, but only 6 LEDs were working too.

https://github.com/adafruit/Adafruit_Ne ... _test2.ino
IMG_5389.jpg
IMG_5389.jpg (107.41 KiB) Viewed 20 times


I think this board is broken.
Could you please replace it with a new one?

order number: #2340036-5944480991
oreder date and time: August 3, 2020 @ 11:34 PM
item: Adafruit NeoTrellis M4 with Enclosure and Buttons Kit Pack
https://www.adafruit.com/product/4020

ca5
 
Posts: 2
Joined: Wed Aug 26, 2020 12:29 pm

Re: NeoTrellisM4 board’s LEDs are not working

by adafruit_support_carter on Thu Aug 27, 2020 5:02 pm

That is looking somewhat suspicious.

Try this test also. Double press the reset button to put the board in bootloader mode and copy this UF2 file to the TRELM4BOOT folder:
TRELLIS_M4_NEOPIXEL_TEST.UF2
(1 MiB) Downloaded 1 time


Any difference?

adafruit_support_carter
 
Posts: 17179
Joined: Tue Nov 29, 2016 2:45 pm

Re: NeoTrellisM4 board’s LEDs are not working

by ca5 on Thu Aug 27, 2020 6:37 pm

I tried it and saw the LEDs change their glowing patterns, but still only 6 seem to glow!
> TRELLIS_M4_NEOPIXEL_TEST.UF2

IMG_5396.jpg
IMG_5396.jpg (143.87 KiB) Viewed 12 times

ca5
 
Posts: 2
Joined: Wed Aug 26, 2020 12:29 pm

Re: NeoTrellisM4 board’s LEDs are not working

by adafruit_support_carter on Thu Aug 27, 2020 7:10 pm

OK. Thanks for testing. Somethings up. Seems like there may be a bad pixel or something. Let's replace it.

Send an email to support@adafruit.com with a link to this thread and your order number and they can send you a replacement NeoTrellis M4 Mainboard (PID 3938).

adafruit_support_carter
 
Posts: 17179
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.