Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

10.1" Display (PID 1287) not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

10.1" Display (PID 1287) not working

by brycekuhlman on Thu Sep 17, 2020 11:34 am

I just got this (https://www.adafruit.com/product/1287) and can't get it to display.

I looked over the forums and, based on the symptoms, it seems this might require a replacement board... but I figured I'd post here first.

What I know:
* Screen is completely black, no matter what I do
* The green LED on the button breakout board is flashing
* I've tried HDMI from two computers (PC and Mac), iPhone and iPad (using an Apple HDMI converter)... and even VGA. Same results: nada.

Like previous posts, I've attached a photo of my connections. I got the recommended power supply from you along with this order.
Attachments
IMG_3073.jpeg
IMG_3073.jpeg (157.08 KiB) Viewed 124 times

brycekuhlman
 
Posts: 6
Joined: Sun Aug 30, 2020 5:44 pm

Re: 10.1" Display (PID 1287) not working

by adafruit_support_carter on Mon Sep 21, 2020 5:57 pm

I got the recommended power supply from you along with this order.

Can you link to the specific power supply you got.

Screen is completely black, no matter what I do

This includes the on screen menu that is brought up with the little buttons?

adafruit_support_carter
 
Posts: 17112
Joined: Tue Nov 29, 2016 2:45 pm

Re: 10.1" Display (PID 1287) not working

by brycekuhlman on Tue Sep 22, 2020 1:39 pm

It was the 12V power supply listed along with the product:

https://www.adafruit.com/product/798

And, yes, the screen is completely blank. No menus. Nada... regardless of button presses.

brycekuhlman
 
Posts: 6
Joined: Sun Aug 30, 2020 5:44 pm

Re: 10.1" Display (PID 1287) not working

by brycekuhlman on Mon Sep 28, 2020 2:00 pm

Hey @adafruit_support_carter,

Any further thoughts?

I unplugged everything and reassembled this weekend... still no dice. The only thing I get is the green LED on the button board. No backlight, menus or anything from the screen (regardless of input type).

Thanks in advance!

brycekuhlman
 
Posts: 6
Joined: Sun Aug 30, 2020 5:44 pm

Re: 10.1" Display (PID 1287) not working

by adafruit_support_carter on Mon Sep 28, 2020 2:06 pm

Sorry for lagging. We're still taking a look on our end. At this point I think we have all the info we need from you. Thanks for providing all of it.

adafruit_support_carter
 
Posts: 17112
Joined: Tue Nov 29, 2016 2:45 pm

Re: 10.1" Display (PID 1287) not working

by brycekuhlman on Tue Oct 13, 2020 9:53 am

So...

Seriously, what's happening?

I feel I've been overly patient here, but it's been almost a month since I first posted. Your customer support people tell me to come to the forums. Y'all say you've got what you need. Yet there's no progress and no communication. I feel like I'm caught in an infinite loop.

I'm not even sure what's happening on your end to "diagnose" the problem. The hardware is still sitting here on my desk.

I realize we're makers and are used to troubleshooting our own problems. Totally fine. It's part of the fun.

But this thing is basically a $150 doorstop. It has been since I first plugged it in. I don't even need my masters in EE and 25 years as a working engineer to know that.

Please... give me some hope. I love Adafruit and always come to you first (even purchased more stuff from you while waiting for this to get worked out). But this is now officially the worst customer service experience I've ever had.

I just want to know someone around there actually cares and that this thing is going to get replaced with a working model.

brycekuhlman
 
Posts: 6
Joined: Sun Aug 30, 2020 5:44 pm

Re: 10.1" Display (PID 1287) not working

by adafruit_support_carter on Thu Oct 15, 2020 5:17 pm

OK, sorry for delay. Let's replace it. We'd like the one you have back for testing - are you in the US?

adafruit_support_carter
 
Posts: 17112
Joined: Tue Nov 29, 2016 2:45 pm

Re: 10.1" Display (PID 1287) not working

by brycekuhlman on Fri Oct 16, 2020 1:53 pm

Yes. Phoenix area.

I still have the original box and everything. I could probably even dig out the anti-static bags (if not I have a stash I can pull from).

Just let me know what to include (the screen, driver, button board, power supply, etc.).

... and whatever process you guys have for the returns.

I'm even happy to pay for return shipping if that's what it takes. I just want to get it working and not complicate things.

Thanks!

brycekuhlman
 
Posts: 6
Joined: Sun Aug 30, 2020 5:44 pm

Re: 10.1" Display (PID 1287) not working

by adafruit_support_carter on Fri Oct 16, 2020 2:34 pm

OK. Thanks. Email support@adafruit.com with a link to this thread and your order number. They can send you a replacement PID 1287 display. Also ask for an "RMA FORPHIL" to have the other display returned. They can also give you details about shipping/packaging etc. for returning the display.

adafruit_support_carter
 
Posts: 17112
Joined: Tue Nov 29, 2016 2:45 pm

Re: 10.1" Display (PID 1287) not working

by brycekuhlman on Fri Oct 16, 2020 2:40 pm

Done. Thank you!

brycekuhlman
 
Posts: 6
Joined: Sun Aug 30, 2020 5:44 pm

Please be positive and constructive with your questions and comments.