Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

LED Backlight Module Stopped Working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

LED Backlight Module Stopped Working

by BeanMartin on Mon Oct 05, 2020 12:06 pm

I recently purchased three of the LED backlight moduleshttps://www.adafruit.com/product/1621--one large and two medium units--for a simple setup: each module was hooked up individually to one of two lipoly batteries.
The medium-size units are functioning just fine, but the large module suddenly stopped lighting up when hooked up to its battery. The first three times I plugged it in to the battery, it lit up with no problem, but after that it has just gone completely dead. Both batteries have been fully charged and I have tried the module with both of them--the medium-size units work perfectly when plugged into either battery, but the large module does not work when plugged into either battery. Nothing appears to be severed or damaged.
When I peeled back the covering to inspect the LED (after thoroughly checking to make sure the module was not working, so peeling back the covering is not what caused the issue), the LED simply fell out of place, without being pushed or anything, so it appears to have been loose and dislodged.
Is there anything I can do to get the large-sized module functioning again?

Thanks!

BeanMartin
 
Posts: 1
Joined: Mon Feb 24, 2020 9:07 pm

Re: LED Backlight Module Stopped Working

by adafruit_support_carter on Wed Oct 14, 2020 2:00 pm

What were you using for a current limiting resistor in your setup?

adafruit_support_carter
 
Posts: 17112
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.