Adafruit is open and shipping! Let's build back better, together!
0

Dead LED in Unicorn Hat HD
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Dead LED in Unicorn Hat HD

by silospen on Sat Oct 24, 2020 11:34 pm

Hey, I bought a Unicorn Hat HD back at the start of October and I just started building with it, when I was testing out colors one pixel looked a bit off and it turns out that when I set all pixels to green, the one in question doesn't light up. Any ideas on fixes, or is it just a defective board?
Attachments
_20201024_202232.JPG
_20201024_202232.JPG (488.55 KiB) Viewed 153 times
_20201024_202232.JPG
_20201024_202232.JPG (488.55 KiB) Viewed 153 times

silospen
 
Posts: 5
Joined: Sat Oct 24, 2020 11:27 pm

Re: Dead LED in Unicorn Hat HD

by silospen on Sun Oct 25, 2020 1:06 am

Here's the front and back of the board, it looks pristine to me, no obvious defects but the leds are tiny.
Attachments
USER_SCOPED_TEMP_DATA_orca_share_media1603601624544_6725992708231540313.jpeg
USER_SCOPED_TEMP_DATA_orca_share_media1603601624544_6725992708231540313.jpeg (356.01 KiB) Viewed 149 times
USER_SCOPED_TEMP_DATA_orca_share_media1603601625697_6725992713068776380.jpeg
USER_SCOPED_TEMP_DATA_orca_share_media1603601625697_6725992713068776380.jpeg (366.14 KiB) Viewed 149 times

silospen
 
Posts: 5
Joined: Sat Oct 24, 2020 11:27 pm

Re: Dead LED in Unicorn Hat HD

by silospen on Sun Oct 25, 2020 11:09 am

And here's a comparison of setting three pixels to r,g,b individually
Attachments
received_636773373675507.jpeg
received_636773373675507.jpeg (130.16 KiB) Viewed 147 times
received_447082102922295.jpeg
received_447082102922295.jpeg (151.99 KiB) Viewed 147 times
received_267845367940326.jpeg
received_267845367940326.jpeg (146.22 KiB) Viewed 147 times

silospen
 
Posts: 5
Joined: Sat Oct 24, 2020 11:27 pm

Re: Dead LED in Unicorn Hat HD

by alphanumeric on Sun Oct 25, 2020 4:59 pm

Looks like a defective LED to me. IMHO 100% a hardware fault.

alphanumeric
 
Posts: 498
Joined: Sun Sep 07, 2014 7:06 pm

Re: Dead LED in Unicorn Hat HD

by silospen on Sun Nov 01, 2020 8:30 pm

Hey Adafruit, what's next here, how can I get a replacement?

silospen
 
Posts: 5
Joined: Sat Oct 24, 2020 11:27 pm

Re: Dead LED in Unicorn Hat HD

by alphanumeric on Mon Nov 02, 2020 5:37 am

You'll likely have to do a https://www.adafruit.com/contact_us with a link to this thread in that e-mail.
I just got my second Unicorn HD a couple of days ago. Mine had two dud red and one dud green. I bought mine directly from Pimoroni though so I did their contact us link. I should get a replay today some time.
If Adafruit tells you to contact Pimoroni just go here
https://shop.pimoroni.com/pages/contact-us

alphanumeric
 
Posts: 498
Joined: Sun Sep 07, 2014 7:06 pm

Re: Dead LED in Unicorn Hat HD

by silospen on Mon Nov 02, 2020 8:19 pm

Thanks, Alphanumeric! Sorry to hear you got a dud too :-(

silospen
 
Posts: 5
Joined: Sat Oct 24, 2020 11:27 pm

Re: Dead LED in Unicorn Hat HD

by alphanumeric on Tue Nov 03, 2020 6:08 am

My replacement shipped from Pimoroni yesterday. =)
I have had very few hardware issues with Pimoroni stuff. Two maybe three items I needed replacements for. About the same here at Adafruit. It happens, it can be a bummer if it holds up your project but it happens sometimes. I won't be using my Unicorn HD until after Christmas, its a Christmas present so no big deal. I tested everything when I got it though so I don't get disappointed on Christmas day and end up past the 30 day return period. ;)

alphanumeric
 
Posts: 498
Joined: Sun Sep 07, 2014 7:06 pm

Re: Dead LED in Unicorn Hat HD

by reid73 on Fri Nov 20, 2020 5:48 pm

Hi All, I recently ordered the Unicorn Hat and it It seems to have the same dead pixel issue too but only two dead"pixels".

unicornHDHat.jpg
unicornHDHat.jpg (303.23 KiB) Viewed 48 times

reid73
 
Posts: 2
Joined: Mon Mar 20, 2017 5:26 pm

Re: Dead LED in Unicorn Hat HD

by alphanumeric on Fri Nov 20, 2020 5:54 pm

My replacement had one dead green pixel. Must be a bad batch of RGB LED's? Pimoroni are going to retest this one before sending it to be sure it doesn't have any defects. Third time is a charm. =)

alphanumeric
 
Posts: 498
Joined: Sun Sep 07, 2014 7:06 pm

Re: Dead LED in Unicorn Hat HD

by alphanumeric on Fri Nov 20, 2020 5:56 pm

this is my test code.
Code: Select all | TOGGLE FULL SIZE
#!/usr/bin/env python

import time
import unicornhathd

unicornhathd.brightness(0.6)

while True:
   
    unicornhathd.clear()
    unicornhathd.set_all(255, 0, 0)
    unicornhathd.show()
    time.sleep(10)

    unicornhathd.clear()
    unicornhathd.set_all(0, 255, 0)
    unicornhathd.show()
    time.sleep(10)

    unicornhathd.clear()
    unicornhathd.set_all(0, 0, 255)
    unicornhathd.show()
    time.sleep(10)




alphanumeric
 
Posts: 498
Joined: Sun Sep 07, 2014 7:06 pm

Re: Dead LED in Unicorn Hat HD

by reid73 on Fri Nov 20, 2020 11:01 pm

Thank you alphanumeric for the test code. Hopefully, this will be your last Unicorn HD Hat =).

reid73
 
Posts: 2
Joined: Mon Mar 20, 2017 5:26 pm

Please be positive and constructive with your questions and comments.