Adafruit is open and shipping! Let's build back better, together!
0

1591 display not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

1591 display not working

by peepo on Wed Nov 04, 2020 7:55 am

Hi,

I have an older 1591 which is as illustrated here:
https://uk.pi-supply.com/products/adafr ... ouchscreen
I have been using it daily with TFT friend for some years.

I need a backup and recently purchased 2 further displays from
https://thepihut.com/products/adafruit- ... ouchscreen
these are as illustrated on your site, in particular have UR branding in large white characters.

when 40pin is swapped into my working system neither display data,
both show bright white screen.

Please can you advise, has there been a pin change or anything else that would cause this?

thanks

Jonathan

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by peepo on Sat Nov 14, 2020 5:02 am

Could some kind & responsible techie post a solution?

tx

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by adafruit_support_carter on Mon Nov 16, 2020 3:10 pm

Can you post a photo showing the displays from the two vendors side-by-side.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: 1591 display not working

by peepo on Mon Nov 16, 2020 6:24 pm

00000000.IMG_0174.jpg
two displays side by side
00000000.IMG_0174.jpg (624.76 KiB) Viewed 116 times


the older one is above, the newer one with RU in white below.

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by adafruit2 on Mon Nov 16, 2020 6:38 pm

what are you using to drive the displays - the controller itself

adafruit2
Site Admin
 
Posts: 19499
Joined: Fri Mar 11, 2005 7:36 pm

Re: 1591 display not working

by peepo on Tue Nov 17, 2020 5:39 am

simple FPGA upduino driving 40 pin TFT friend ID:1932 connected to display.
I am only switching display's 40pin fpc, on a working system.
the old one outputs data, the two identicalnew ones display bright whitescreen.

tx

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by adafruit2 on Tue Nov 17, 2020 9:42 pm

could it be some timing difference? cause we use these with a raspberry pi/RA8875/TI TFP4x without issue. we only have the new type, we could not replace it with the old one. maybe the old one was less sensitive to timing/polarity differences!

adafruit2
Site Admin
 
Posts: 19499
Joined: Fri Mar 11, 2005 7:36 pm

Re: 1591 display not working

by peepo on Wed Nov 18, 2020 4:51 am

I would expect timing differences to display jitter, some data, or intermittent end of line or frame.

Wouldn't a white screen indicate that no timing signals are being received?

Do you have experience with these displays?
if not,
Please could you bump to an engineer who has?

thanks again

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by peepo on Wed Nov 18, 2020 6:09 am

It is possible that timing is the issue,
however in my rather limited experience, newer products tend to support more, rather than less.

It will take some time to test these screens with other timings!

regards

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by peepo on Wed Nov 18, 2020 10:12 am

Hi Carter,

regarding timings:
please can you check: has the datasheet changed?
the data sheet is the same, so the timings given are currently the same as for the earlier 1591,

have 5mhz 9mhz and 12mhz been tested on the raspberry pi?
my tests which are a work in progress, currently show differences, dependent on the clock frequency.

thanks again

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by adafruit2 on Wed Nov 18, 2020 12:11 pm

yeah a white screen could definitely be unexpected vsync/hsync polarity or pulse widths, we'll ask for if there's a new datasheet

this is the raspi timing
https://learn.adafruit.com/adafruit-dpi ... 2001043-21
https://www.raspberrypi.org/documentati ... /README.md

adafruit2
Site Admin
 
Posts: 19499
Joined: Fri Mar 11, 2005 7:36 pm

Re: 1591 display not working

by peepo on Wed Nov 18, 2020 1:37 pm

thanks, I have the new screen display output correctly, but as you say the timings are different.
as you say vsync/hsync is different.

Not clear to me if they will be compatible...

looking forward to the 'new datasheets'

thanks

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Re: 1591 display not working

by adafruit2 on Sat Nov 21, 2020 12:56 pm

ok this is a specsheet we got from the TFT factory
Attachments
SPEC-CH430WQ09A-T V0.pdf
(907.31 KiB) Downloaded 1 time

adafruit2
Site Admin
 
Posts: 19499
Joined: Fri Mar 11, 2005 7:36 pm

Re: 1591 display not working

by peepo on Tue Nov 24, 2020 1:35 pm

okay thanks, had a look today, 7.2.3 RGB timings are identical,

7.1 Power ON/OFF Sequence seems somewhat different to the previous version: SPEC-CH430WQ01-T_Rev.A.pdf
could you comment?

I did not immediately find any other significant differences.

cheers

peepo
 
Posts: 14
Joined: Fri Apr 24, 2015 9:18 am

Please be positive and constructive with your questions and comments.