Adafruit is open and shipping! Let's build back better, together!
0

TFT 3.5" 480x320 not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 13, 2020 4:37 pm

My Adafruit TFT FeatherWing - 3.5" 480x320 Touchscreen does not pass the basic graphics test.
Order Confirmation No: 2397073-4535857034 ordered Oct 28, 2020
https://www.adafruit.com/product/3651

I have followed the instructions for the TFT Graphics Test (https://learn.adafruit.com/adafruit-3-5 ... phics-test) and I get the following message on the IDE serial console:

[begin code]
HX8357D Test!
Display Power Mode: 0x0
MADCTL Mode: 0x0
Pixel Format: 0x0
Image Format: 0x0
Self Diagnostic: 0x0
Benchmark Time (microseconds)
Text 137006
Lines 458869
Rectangles (outline) 44964
Circles (outline) 199643
Triangles (outline) 93310
Triangles (filled) 772488
Rounded rects (outline) 64352
Rounded rects (filled) 1617303
Done!
[end code]

For the graphics test, I am using the graphicstest_featherwing sketch which is part of the HX8357 library (https://github.com/adafruit/Adafruit_HX8357_Library).

I am using a Teensy 4.1 (https://www.pjrc.com/store/teensy41.html) as the microcontroller. I have also tried this display on an Adafruit Tinket M0 and get the same results. For the Teensy, I modified the graphicstest_featherwing sketch by commenting out the initial #define statements and using:

[begin code]
// For Teensy 4.1
#define TFT_DC 4
#define TFT_CS 10
#define TFT_MOSI 11
#define TFT_CLK 13
#define TFT_MISO 12
#define TFT_RST -1
Adafruit_HX8357 tft = Adafruit_HX8357(TFT_CS, TFT_DC, TFT_MOSI, TFT_CLK, TFT_RST, TFT_MISO);
[end code]

I wired up the display using the above pin assignments as shown in the photo. When I run the sketch, the screen goes through different levels of brightness, that is different shades of white/grey.
[img]
TFT%20to%20Teensy.jpg
[/img]
The schematic for the TFT (https://learn.adafruit.com/assets/47657) shows the ground pin for the TFT in a different location than in the pinout (https://learn.adafruit.com/adafruit-3-5 ... ng/pinouts). I have tried the ground in both locations and get the same results.

Any ideas about what I should try next?
Attachments
TFT to Teensy.jpg
TFT to Teensy.jpg (310.87 KiB) Viewed 98 times

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 3:45 pm

You are using the FeatherWing version of the TFT, which was meant to be used with a Feather mainboard. The same display is available in a breakout version:
https://www.adafruit.com/product/2050
which is better suited for general purpose use.

Do you have a Feather main board?

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 3:58 pm

No, I do not have a feather main board.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 4:15 pm

I thought that as long as I connected the MISO, MOSI, CLK, DC, SC, and power pins that it should work.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 4:49 pm

In general, it should work. But there may be other pins you need to pay attention to since it assumes you are attaching to a Feather.

How is power being applied to the power rail on the breadboard? I see GND going back to the Teensy. But not power. The two red wires appear to go to the TFT.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 5:04 pm

I'm using a breadboard power supply - picture attached. Both the Teensy and TFT are connected to the same ground as the power supply, set to 3.3 V. On the TFT, the ground goes to the fourth pin from the left on the larger (foreground) block.
Attachments
PowerSupply.jpg
PowerSupply.jpg (569.43 KiB) Viewed 70 times

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 5:06 pm

And the Teensy gets its power from the USB connection. The serial output to the Arduino ADI works, so the Teensy is functioning properly.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 5:10 pm

Can you post a photo showing the entire breadboard and setup.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 5:34 pm

A photo of the whole board is attached. I added a jumper from the 3.3V rail to the Teensy Vin and I still get the same behavior. The Arduino IDE serial monitor shows the same messages and the graphicstest_featherwing sketch works fine. The TFT blinks through different shades of grey.
Attachments
Whole Board.jpg
Whole Board.jpg (375.25 KiB) Viewed 69 times

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 5:42 pm

Your breadboard has split power rails. The power supply will not reach the other end.
breadboard.jpg
breadboard.jpg (128.61 KiB) Viewed 68 times

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 5:50 pm

Good catch. I moved the power supply to the proper rail and the display still just blinks. The serial message changed to:
HX8357D Test!
Display Power Mode: 0xFF
MADCTL Mode: 0xFF
Pixel Format: 0xFF
Image Format: 0xFF
Self Diagnostic: 0xFF
Benchmark Time (microseconds)
Text 137006
Lines 458869
Rectangles (outline) 44964
Circles (outline) 199643
Triangles (outline) 93310
Triangles (filled) 772486
Rounded rects (outline) 64352
Rounded rects (filled) 1617303
Done!

So now the mode diagnostics has changed from "0x0" to "0xFF". But the display is still blinking.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 6:02 pm

Are these headers soldered?
headers.jpg
headers.jpg (63.25 KiB) Viewed 55 times

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 6:07 pm

Yes, the headers are soldered to the Teensy board. (And as a ham radio operator, I've had quite a bit of experience soldering, so the connections are good.)

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 6:11 pm

Remove the external power supply and set everything up powered through the Teensy. Post a photo of the new setup.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 6:26 pm

OK. Now it is running entirely on USB power and it still does the same blinking without the expected graphics.
Attachments
WithNoPower.jpg
WithNoPower.jpg (65.4 KiB) Viewed 54 times

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Please be positive and constructive with your questions and comments.