Adafruit is open and shipping! Let's build back better, together!
0

TFT 3.5" 480x320 not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 6:44 pm

There's no GND connection?
bb.jpg
bb.jpg (56.34 KiB) Viewed 14 times


Also keep in mind this behavior w.r.t. the backlight:
https://learn.adafruit.com/adafruit-3-5 ... ep-2928515

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 7:13 pm

Maybe the explanation for power at https://learn.adafruit.com/adafruit-3-5 ... ep-2928515 is a little confusing. The way I read it for the first picture under Power Pins, we have:
VBAT is 4th from the right on the top set of pins
VUSB is 2nd from the right on the top set of pins
GND is 3rd from the right on the lower set of pins
3.3V is on the right on the lower set of pins

Is this correct? Or is the 4th from the right on the top really a ground?

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Fri Nov 20, 2020 7:27 pm

The standard Feather pinout information is here:
https://learn.adafruit.com/adafruit-fea ... cification
The TFT FeatherWing schematics are here:
https://learn.adafruit.com/adafruit-3-5 ... /downloads

You will need to carefully examine both of those to figure out how to use the TFT without a Feather mainboard.

I grabbed an Itsy Bitsy M4 just to verify such a thing could be done. I got it to work using the hardware SPI pins along with 9 for TFT_CS and 10 for TFT_DC. GND to GND. 3V to 3V. I connect TFT Featherwing USB pin to USB pin on the Itsy so that the backlight would be powered via USB 5V.

The SD and touch CS pins are pulled up to 3.3V, so should be able to be left alone.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Fri Nov 20, 2020 7:31 pm

Thanks. I'll take a look at these tomorrow and post back here after that.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by RonNelson on Sat Nov 21, 2020 3:33 pm

Your Feather pinout and FeatherWing schematic agree:
https://learn.adafruit.com/adafruit-fea ... cification
https://learn.adafruit.com/adafruit-3-5 ... /downloads
So, I'll use the schematic for my setup.
[As a side note, the pinout given in https://learn.adafruit.com/adafruit-3-5 ... ep-2928515 is confusing and it's hard to tell which pin is which. Maybe this needs to be re-written to clarify.}

Using the schematic, I set up my connections as in the photo. Then on the Arduino IDE Serial Monitor, I get:
HX8357D Test!
Display Power Mode: 0x0
MADCTL Mode: 0x0
Pixel Format: 0x0
Image Format: 0x0
Self Diagnostic: 0x0
Benchmark Time (microseconds)
Text 137006
Lines 458869
Rectangles (outline) 44964
Circles (outline) 199643
Triangles (outline) 93310
Triangles (filled) 772486
Rounded rects (outline) 64352
Rounded rects (filled) 1617303
Done!

The TFT backlight is on continuously and is not blinking as before. If I turn the breadboard power supply off, then the TFT starts blinking - maybe due to an overloaded power draw from the Teensy. But, I still don't get the expected graphics.

For the graphicstest_featherwing sketch, I'm using:
// For Teensy 4.1
#define TFT_DC 9
#define TFT_CS 10
#define TFT_MOSI 11
#define TFT_MISO 12
#define TFT_CLK 13
#define TFT_RST -1
Adafruit_HX8357 tft = Adafruit_HX8357(TFT_CS, TFT_DC, TFT_MOSI, TFT_CLK, TFT_RST, TFT_MISO);
Attachments
Teensy TFT with Power.jpg
Teensy TFT with Power.jpg (486.87 KiB) Viewed 13 times

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Sat Nov 21, 2020 4:12 pm

It could be a loose connection. When I set this up, I noticed the wires did not go into the TFT headers very securely. If I even bumped the setup, I'd no longer get output on the TFT.

What's your end goal with this hardware?

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Sat Nov 21, 2020 4:29 pm

I've wiggled all of the connections many times while there should be graphics being displayed. I've also tried the other set of SPI pins on the Teensy and still get the same results.

I have an audio adapter for the Teensy and my end goal is to have a spectral display of the frequencies around where my radio is tuned. The audio input and FFT are working and I can see the numbers on the IDE serial monitor, but the serial monitor is not the best for displaying a spectral distribution. The TFT should work well for that display.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Sat Nov 21, 2020 4:42 pm

And the Teensy is what you plan to use to drive the display in the final setup? Not just for development?

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Sat Nov 21, 2020 4:50 pm

That's right. The Teensy should have enough speed and memory to handle this project. And once it is working, I'll package it up in a box.

The kickoff for my college football team is in 10 minutes, so I'll be busy with that for a while. I may not be able to get back to this thread for a day or two. Thanks.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Sat Nov 21, 2020 5:02 pm

No worries, just trying to think of ways you could better connect the two items together.

One option might be something like this:
https://www.adafruit.com/product/2884
which you could use as sort of breakout for the TFT. Solder headers to that, which would mate securely with the TFT. Then you could solder wires to the secondary row on the proto wing and connect those to the Teensy.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Sat Nov 21, 2020 5:13 pm

There's also this:
https://www.adafruit.com/product/3200
which maybe could be made to work with your specific Teensy.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Wed Nov 25, 2020 4:39 pm

I finally got this to work. From what I can tell, the pins that go in the back of the TFT have to be in the top row of sockets. And, even those are flakey. If I wiggle the pins just right, the display works. So, my next step is to solder some wires to the back solder tabs. Thanks for your help and I think this issue is now resolved.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by RonNelson on Wed Nov 25, 2020 4:47 pm

Actually, your suggestion https://www.adafruit.com/product/2884 above might be good to solder the wires to. I'll probably do something like that.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Re: TFT 3.5" 480x320 not working

by adafruit_support_carter on Wed Nov 25, 2020 5:56 pm

I'd suggest trying to find a solution that doesn't require soldering directly to the TFT. The header pins that come with the PID 2884 will mate much more solidly than the breadboard wires.

adafruit_support_carter
 
Posts: 17777
Joined: Tue Nov 29, 2016 2:45 pm

Re: TFT 3.5" 480x320 not working

by RonNelson on Wed Nov 25, 2020 6:32 pm

I just ordered PID 2884 and will go that route. Thanks.

RonNelson
 
Posts: 18
Joined: Sun Feb 12, 2017 11:05 am

Please be positive and constructive with your questions and comments.