Adafruit is open and shipping! Let's build back better, together!
0

One LED is not turning ON in my NeoPixel Stick - 8 x 5050 RG
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

One LED is not turning ON in my NeoPixel Stick - 8 x 5050 RG

by NanogearTech on Sat Nov 21, 2020 12:32 am

Hello,

Just wanting to know if there is a solution to a little thing that is happening on my Neopixel...

Background:

*Neopixel directly connected to a Nvidia Jetson Nano 2Gb using the SPI ports(2 Gnd to Jetson Gnd’s, DIN to SPI1_MOSI, 5vdc to 5v ). Drivers and every piece of software correctly installed.

*Neopixel is the one with the 470 Ohm resistor at the first LED.

*Running the attached code turns ON and OFF every pixel(led) individually and sequentially. RGB colours.

The problem I have is that the 5th LED not always turn ON when running the code... actually almost never turn ON, just a few times randomly... why?

Video that demonstrate the issue:
https://youtu.be/dlkHRo1-VIE

Hope someone can help me and put me in the right direction.

Thank you in advance and kind regards,

-nanogear

Code: Select all | TOGGLE FULL SIZE
import time
import board
import neopixel_spi as neopixel
 
NUM_PIXELS = 12
PIXEL_ORDER = neopixel.GRB
COLORS = (0xFF0000, 0x00FF00, 0x0000FF)
DELAY = 0.1
 
spi = board.SPI()
 
pixels = neopixel.NeoPixel_SPI(
    spi, NUM_PIXELS, pixel_order=PIXEL_ORDER, auto_write=False
)
 
while True:
    for color in COLORS:
        for i in range(NUM_PIXELS):
            pixels[i] = color
            pixels.show()
            time.sleep(DELAY)
            pixels.fill(0)

NanogearTech
 
Posts: 2
Joined: Fri Nov 20, 2020 9:59 pm

Re: One LED is not turning ON in my NeoPixel Stick - 8 x 505

by NanogearTech on Sat Nov 21, 2020 2:47 pm

Testing all LED’s with this code:

Code: Select all | TOGGLE FULL SIZE
import board
import neopixel_spi

pixels = neopixel_spi.NeoPixel_SPI(board.SPI(), 8)
pixels.fill(0xff0000)




Can I securely say that I have a defective Neopixel because only 4 led’s show the correct Purple colour?
Attachments
C32B5216-9971-4089-B1D7-87E2B690AD5B.jpeg
C32B5216-9971-4089-B1D7-87E2B690AD5B.jpeg (289.88 KiB) Viewed 32 times

NanogearTech
 
Posts: 2
Joined: Fri Nov 20, 2020 9:59 pm

Please be positive and constructive with your questions and comments.