0

neopixel issue with Arduino Nano 33 BLE
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

neopixel issue with Arduino Nano 33 BLE

by vonderasche on Sat Apr 10, 2021 12:40 am

I am getting a strange error while trying to use neopixel library with nano 33 ble sense.

I am trying to run the "simple" sketch and receive the following error. I have also tried StandtestBle with the same error.

I am able to run the sketches on my arduino uno and regular nano.

C:\Users\nieba\OneDrive\Desktop\arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp: In member function 'void Adafruit_NeoPixel::show()':
C:\Users\nieba\OneDrive\Desktop\arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp:1519:45: error: invalid use of incomplete type 'PinDescription {aka struct _PinDescription}'
pwm->PSEL.OUT[0] = g_APinDescription[pin].name;
^
In file included from C:\Users\nieba\OneDrive\Desktop\arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.h:41:0,
from C:\Users\nieba\OneDrive\Desktop\arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp:46:
C:\Users\nieba\AppData\Local\arduino15\packages\arduino\hardware\mbed\2.0.0\cores\arduino/Arduino.h:83:16: note: forward declaration of 'PinDescription {aka struct _PinDescription}'
typedef struct _PinDescription PinDescription;
^~~~~~~~~~~~~~~
exit status 1
Error compiling for board Arduino Nano 33 BLE

vonderasche
 
Posts: 5
Joined: Sat Feb 25, 2017 3:19 am

Re: neopixel issue with Arduino Nano 33 BLE

by mikeysklar on Sun Apr 11, 2021 9:09 pm

Looks like a board support issue, but not necessarily in the NeoPixel library. Are you able to run any Arduino code on your Nano 33 BLE? It appears that you are either missing the board support package for this newer Nano 33 or that your Arduino IDE a whole might need to be updated to have a more modern compiler to support the new board definitions.

mikeysklar
 
Posts: 4624
Joined: Mon Aug 01, 2016 8:10 pm

Re: neopixel issue with Arduino Nano 33 BLE

by V_ger on Mon Apr 12, 2021 4:46 am

Hi
Having the same issue/error message while trying to use version 1.2.0 of NeoMatrix library (and dependencies) on Arduino IDE 1.8.13 & 2.0 Beta with Arduino Nano 33 BLE to manage a WS2812 32x8 RVB LED matrix.

Basic ArduinoBLE example sketches work fine so I take it support for this type of board is correctly installed.

Output below
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
C:\Users\XXXX\Documents\Arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp: In member function 'void Adafruit_NeoPixel::show()':
C:\Users\XXXX\Documents\Arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp:1519:45: error: invalid use of incomplete type 'PinDescription {aka struct _PinDescription}'
pwm->PSEL.OUT[0] = g_APinDescription[pin].name;
^
In file included from C:\Users\XXXX\Documents\Arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.h:41:0,
from C:\Users\XXXX\Documents\Arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp:46:
C:\Users\XXXX\AppData\Local\Arduino15\packages\arduino\hardware\mbed_nano\2.0.0\cores\arduino/Arduino.h:83:16: note: forward declaration of 'PinDescription {aka struct _PinDescription}'
typedef struct _PinDescription PinDescription;
^~~~~~~~~~~~~~~
Compilation error: Error: 2 UNKNOWN: exit status 1

Any idea ?

V_ger
 
Posts: 1
Joined: Mon Apr 12, 2021 4:38 am

Re: neopixel issue with Arduino Nano 33 BLE

by mikeysklar on Mon Apr 12, 2021 6:39 pm

Looks like there might be some confusion in ArduinoCoreSAMD variant file.

https://github.com/arduino/ArduinoCore- ... ariant.cpp

It might be pin specific. What pin are you using to drive the NeoPixels? Can you try another?

https://github.com/arduino/ArduinoCore-samd/issues/461

mikeysklar
 
Posts: 4624
Joined: Mon Aug 01, 2016 8:10 pm

Re: neopixel issue with Arduino Nano 33 BLE

by vonderasche on Tue Apr 13, 2021 12:26 am

Thank you for the links, I looked over both. It seems the link for the variant is for the nano 33 iot. I have the nano 33 ble. I did however download the Arduino Core for SAMD21 CPU nightly build anyway. This only had the nano 33 iot. Using iot things version didn't work at all. I selected the board again as the nano 33 ble and tried various pins. None of the pins I tried worked.

Since I needed to finish the project soon I ordered an adafruit 3 axis accelerometer. I already had a arduino nano, Bluetooth module and adafruit powerboost 500 board on hand.

Would you know if there are any compatibility issues with the Adafruit Feather nRF52840 Sense and neopixels? Using this board I would only need a logic shifter from 3v - 5v instead of 3 additional boards.

vonderasche
 
Posts: 5
Joined: Sat Feb 25, 2017 3:19 am

Re: neopixel issue with Arduino Nano 33 BLE

by mikeysklar on Tue Apr 13, 2021 2:09 pm

Thanks for reviewing those links. I was not familiar with the Nano 33 IoT vs BLE models. Both are pretty foreign to us.

The Feather Sense can work as direct drive for NeoPixels (no level shiftting required) if you are running a modest amount of them (say less than a dozen). If you are going to run a large amount of NeoPixels then it would make sense to boost the strength and add in a level shifter. In both cases and outside 5v power supply to drive the NeoPixels will be necessary. What and how many NeoPixel device were you planning on driving?

mikeysklar
 
Posts: 4624
Joined: Mon Aug 01, 2016 8:10 pm

Re: neopixel issue with Arduino Nano 33 BLE

by vonderasche on Tue Apr 13, 2021 4:48 pm

I will definitely get a Adafruit Feather nRF52840 Sense.

A friend of mine wanted me to put together shoes that have leds around the sole. Rather than just having the leds display static colors. I created an app to select the color of the lights along with an effect to be played when a step or jump is detected. Using a feather with a level shifter makes more sense then my current setup of an Arduino nano, Bluetooth, triple-axis accelerometer and powerboost. I have an adafruit lipo battery that drives the pixels and electronics separately.

thank you for the support.

vonderasche
 
Posts: 5
Joined: Sat Feb 25, 2017 3:19 am

Re: neopixel issue with Arduino Nano 33 BLE

by mikeysklar on Wed Apr 14, 2021 2:32 pm

Those sounds like cool sneaks. A modern version of our "Firewalkers". Please post pics / vid / link of your shoes when they are done.

https://learn.adafruit.com/firewalker-led-sneakers

mikeysklar
 
Posts: 4624
Joined: Mon Aug 01, 2016 8:10 pm

Re: neopixel issue with Arduino Nano 33 BLE

by jellybean568 on Mon Apr 26, 2021 1:57 pm

Hello, I'm also having the same problem for the Arduino BLE Sense:
Arduino15\packages\arduino\hardware\mbed_nano\2.0.0\cores\arduino/Arduino.h:83:16: note: forward declaration of 'PinDescription {aka struct _PinDescription}'
typedef struct _PinDescription PinDescription;
^~~~~~~~~~~~~~~
exit status 1

I tried using different pins, which didn't work.
Is there something else I can try?
For my project, I just need to have the LED turn on.

jellybean568
 
Posts: 2
Joined: Mon Apr 26, 2021 1:51 pm

Re: neopixel issue with Arduino Nano 33 BLE

by mikeysklar on Mon Apr 26, 2021 3:23 pm

@jellybean568,

It looks to me like the Arduino Nano 33 BLE / Sense and other models were included in the Adafruit_NeoPixel library since October 2019. With everything working in Dec. 2019.

https://github.com/adafruit/Adafruit_NeoPixel/pull/209

Make sure you are running the current Adafruit_NeoPixel library from github and the latest Arduino Mbed Core board library.

https://forum.arduino.cc/t/nano-33-ble- ... d/621618/8

https://github.com/adafruit/Adafruit_NeoPixel

mikeysklar
 
Posts: 4624
Joined: Mon Aug 01, 2016 8:10 pm

Re: neopixel issue with Arduino Nano 33 BLE

by jellybean568 on Sun May 02, 2021 7:46 pm

Thank you, I just checked.
I do have the latest core and the latest NeoPixel library.
However, I am still getting the same error.
Attachments
Capture6.PNG
Capture6.PNG (7.61 KiB) Viewed 296 times
Capture7.PNG
Capture7.PNG (8.99 KiB) Viewed 296 times

jellybean568
 
Posts: 2
Joined: Mon Apr 26, 2021 1:51 pm

Re: neopixel issue with Arduino Nano 33 BLE

by mikeysklar on Mon May 03, 2021 3:53 pm

@jellybean568,

This is a new one to me. It's not coming from the NeoPixel side, but the ArduinoCore-mbed. Can you open an issue with them.

https://github.com/arduino/ArduinoCore-mbed/issues

mikeysklar
 
Posts: 4624
Joined: Mon Aug 01, 2016 8:10 pm

Re: neopixel issue with Arduino Nano 33 BLE

by kaunglvlv on Sun May 16, 2021 7:26 pm

I had this problem on the ArduinoIDE. Same on VSCode with Arduino Extenstion. Switched over to PlatformIO and compiled/uploaded successfully. The other day I started a project for an ESP32 board then went back to this project and now PlatformIO is also showing this same issue. smh

kaunglvlv
 
Posts: 1
Joined: Sun May 16, 2021 7:22 pm

Re: neopixel issue with Arduino Nano 33 BLE

by silvan2468 on Sat May 22, 2021 3:39 am

Hy there

I have the same problem now. Only that it worked some months ago.
In these months I bought a new pc and had to install everything new. Now I am no longer able to compile :(

Because there were a lot of new versions of the board organizer "Arduino Mbed OS Boards" in these few months, I tried an older verison. Exactly Version 1.3.0. And with this, compilation is successfull!!
So there IS definetively a bug in the newer version.

Kind regards
Silvan

silvan2468
 
Posts: 4
Joined: Wed Dec 30, 2020 7:53 am

Re: neopixel issue with Arduino Nano 33 BLE

by mikeysklar on Sun May 23, 2021 4:10 pm

@silvan2468,

Good find that an older library release is working for you.

Can I ask which libraries in between the current release (2.1.0 - released last week) and the one you are using (1.3.0 - Oct 2020) you had tried if any? Just trying to narrow down where a bug might have snuck in here to report it.

https://github.com/arduino/ArduinoCore-mbed/tags

AA5C0513-D972-493B-9FE9-793E095A0A84.jpeg
AA5C0513-D972-493B-9FE9-793E095A0A84.jpeg (162.69 KiB) Viewed 189 times

mikeysklar
 
Posts: 4624
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.