Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

Glitchy Flickering LEDs on LED Matrix
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Glitchy Flickering LEDs on LED Matrix

by keenest on Mon May 10, 2021 10:25 am

I am experiencing flickering of random LEDs typically in the upper left portion of the LED matrix using a Matrix Portal. See this thread https://forums.adafruit.com/viewtopic.php?f=19&t=171696&start=15 where I did some testing and troubleshooting including using a 5V 4A power supply. The replacement LED matrix has the same behavior.

keenest
 
Posts: 19
Joined: Wed Apr 14, 2021 7:24 pm

Re: Glitchy Flickering LEDs on LED Matrix

by mikeysklar on Tue May 11, 2021 6:23 pm

@keenest,

Could you provide a photo of the back of the Matrix Portal. If you have done any soldering or custom connections yourself please provide pics of that. I have seen a few units were some surface mount components looked as though they were soldered on a single side so I wanted to verify this was assembled correctly.

mikeysklar
 
Posts: 4559
Joined: Mon Aug 01, 2016 8:10 pm

Re: Glitchy Flickering LEDs on LED Matrix

by keenest on Wed May 12, 2021 9:48 am

PXL_20210512_132306982.jpg
PXL_20210512_132306982.jpg (957.53 KiB) Viewed 235 times


PXL_20210512_132228604.MP.jpg
PXL_20210512_132228604.MP.jpg (914.04 KiB) Viewed 235 times

keenest
 
Posts: 19
Joined: Wed Apr 14, 2021 7:24 pm

Re: Glitchy Flickering LEDs on LED Matrix

by mikeysklar on Wed May 12, 2021 11:29 am

Thanks for the photos. I actually wanted to see the LED matrix surface mount components and should have phrased that differently. Can you post photos of the backside of the LED matrix you are using?

mikeysklar
 
Posts: 4559
Joined: Mon Aug 01, 2016 8:10 pm

Re: Glitchy Flickering LEDs on LED Matrix

by keenest on Thu May 13, 2021 12:01 pm

PXL_20210513_155215010.jpg
PXL_20210513_155215010.jpg (964.85 KiB) Viewed 224 times


PXL_20210513_155230286.jpg
PXL_20210513_155230286.jpg (965.68 KiB) Viewed 224 times


PXL_20210513_155240911.jpg
PXL_20210513_155240911.jpg (954.8 KiB) Viewed 224 times

keenest
 
Posts: 19
Joined: Wed Apr 14, 2021 7:24 pm

Re: Glitchy Flickering LEDs on LED Matrix

by keenest on Thu May 13, 2021 12:04 pm

Also note that in the other thread a replacement LED display was sent. Both are experiencing the same issue.

keenest
 
Posts: 19
Joined: Wed Apr 14, 2021 7:24 pm

Re: Glitchy Flickering LEDs on LED Matrix

by mikeysklar on Thu May 13, 2021 2:33 pm

Okay, thank you for taking the time to get these pics here.

Can you try running the "glitchy" code on either display and gently pressing on some of the chips UR4, UB4 or UG4 for example. Especially if any of them look as though on side might be unsoldered. Your pics are good, but not quite high quality enough for me to confirm that all the pins have be soldered down.

If they all look well soldered and lightly pressing them doesn't immediately resolve this we can give up on this line of troubleshooting and go another direction.

mikeysklar
 
Posts: 4559
Joined: Mon Aug 01, 2016 8:10 pm

Re: Glitchy Flickering LEDs on LED Matrix

by keenest on Fri May 14, 2021 9:06 am

Ok, I just tried that and I looked closely for any soldering issues. None are sticking out to me. I created this photo album with hi-res photos so you can look at them. Also, it would seem that if the issue was with a particular section of the LED display, the little red guy image at the top left of the display, shown in the the album, would also be glitchy.

https://photos.app.goo.gl/NfRsd5FL3K8CmSK19

keenest
 
Posts: 19
Joined: Wed Apr 14, 2021 7:24 pm

Re: Glitchy Flickering LEDs on LED Matrix

by xsk8rat on Fri May 14, 2021 10:57 am

Similar behavior, started this week for me. There are streaks of similar color on the LED panel - which was cool - until the display stopped. :^(
Just started watching it while working. Checked the connections, but will monitor what i can.

Edit: This was the display in the ADABOX16 (PRODUCT ID: 2278) which has been running continuously since November 2020.

xsk8rat
 
Posts: 16
Joined: Thu Aug 21, 2014 12:43 am

Re: Glitchy Flickering LEDs on LED Matrix

by keenest on Fri May 14, 2021 11:43 am

@xsk8rat, do you have a flexible LED panel or the standard hard back? Mine are the flexible panels.

keenest
 
Posts: 19
Joined: Wed Apr 14, 2021 7:24 pm

Re: Glitchy Flickering LEDs on LED Matrix

by xsk8rat on Fri May 14, 2021 12:20 pm

Running fine so far (this is running the sample clock code).
The Matrix Portal is running fairly cool - roughly room temperature.
The chips on the display are running about 6C above room temperature (~32C to 33C).

xsk8rat
 
Posts: 16
Joined: Thu Aug 21, 2014 12:43 am

Re: Glitchy Flickering LEDs on LED Matrix

by xsk8rat on Fri May 14, 2021 12:21 pm

@Keenest,
No, these are the ones in the frame.
Should i add a new post? I don't want to confuse your issue.

xsk8rat
 
Posts: 16
Joined: Thu Aug 21, 2014 12:43 am

Re: Glitchy Flickering LEDs on LED Matrix

by keenest on Fri May 14, 2021 12:28 pm

I was just curious is that was something in common here. Sounds like you are having a similar problem maybe we can troubleshoot with support to resolve.

keenest
 
Posts: 19
Joined: Wed Apr 14, 2021 7:24 pm

Re: Glitchy Flickering LEDs on LED Matrix

by mikeysklar on Fri May 14, 2021 12:33 pm

Since there are multiple folks on this thread with similar hardware would you each mind summarizing your setups so we can determine if this is a hardware, firmware, library or example code code issue.

LED Matrix Product: #2279 (64x32 3mm)
Glitchy Presentation: (eg. top left static)

Controller: ( Uno, Metro M4, etc.)

Example Code: (script name)

Bootloader Version:

Arduino or CircuitPython:

Library version for RGBmatrixPanel:

mikeysklar
 
Posts: 4559
Joined: Mon Aug 01, 2016 8:10 pm

Re: Glitchy Flickering LEDs on LED Matrix

by xsk8rat on Fri May 14, 2021 12:37 pm

Following the temperature thing that i am trying to rule out or not...
Was your's in a case or out in the open?
Mine was in a PLA case with the covering that came in the https://www.adafruit.com/product/4812.
So i was wondering if that might have lead to an overheating thing.

xsk8rat
 
Posts: 16
Joined: Thu Aug 21, 2014 12:43 am

Please be positive and constructive with your questions and comments.