0

2.5" TFT display no signal
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

2.5" TFT display no signal

by vulpinaut on Thu Jun 03, 2021 6:01 pm

Picked up one of the 2.5" TFT displays (product no. 912) for a relatively simple project, just trying to connect it to a small camera from a drone and power it all via 12V battery. However when connected the display backlight turns on but doesn't appear to be receiving any input. Testing the camera independently it works fine, everything seems to be receiving the appropriate power. This is my first kind of custom electronics project so it could be something extremely obvious I'm just missing, but pictures of the complete system are attached. I've been using this build guide as a rough reference and he also used an Adafruit display in the same implementation, so I'm a bit confused as to what isn't working here. https://www.instructables.com/3D-Printe ... OpenScope/.

Any input would be helpful.
Attachments
ada.jpg
ada.jpg (877.05 KiB) Viewed 297 times

vulpinaut
 
Posts: 6
Joined: Thu Jun 03, 2021 5:43 pm

Re: 2.5" TFT display no signal

by adafruit_support_mike on Thu Jun 03, 2021 10:29 pm

Does the display work with a signal from any other NTSC/PAL video source?

adafruit_support_mike
 
Posts: 63052
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.5" TFT display no signal

by vulpinaut on Fri Jun 04, 2021 1:49 am

adafruit_support_mike wrote:Does the display work with a signal from any other NTSC/PAL video source?



Unfortunately I don't have a Composite video source to test with. Is the TFT display supposed to have some kind of OSD where I can check settings and make sure its in the right mode? The camera also outputs NTSC/PAL, but im not sure which one it's in by default.

vulpinaut
 
Posts: 6
Joined: Thu Jun 03, 2021 5:43 pm

Re: 2.5" TFT display no signal

by adafruit_support_mike on Fri Jun 04, 2021 9:29 pm

NTSC and PAL are pretty much interchangeable, and the dispay should be able to use either without any trouble.

That display doesn't have any hardware test mode, so we need to do comparison tests.

Do you have any other display that can show output from the camera?

adafruit_support_mike
 
Posts: 63052
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.5" TFT display no signal

by vulpinaut on Fri Jun 04, 2021 11:11 pm

Yes, swapping the connector to attach it to a drone I have, it works fine and displays normally.

vulpinaut
 
Posts: 6
Joined: Thu Jun 03, 2021 5:43 pm

Re: 2.5" TFT display no signal

by adafruit_support_mike on Sat Jun 05, 2021 9:12 pm

Good, that rules out problems on the camera side.

There isn't much more debugging to be done with those displays. Send a note containing a link to this page and your order number to support@adafruit.com. The folks there will get you a replacement.

adafruit_support_mike
 
Posts: 63052
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.5" TFT display no signal

by vulpinaut on Sat Jun 05, 2021 9:48 pm

adafruit_support_mike wrote:Good, that rules out problems on the camera side.

There isn't much more debugging to be done with those displays. Send a note containing a link to this page and your order number to support@adafruit.com. The folks there will get you a replacement.



Will do. Thank you for your input, Mike.

vulpinaut
 
Posts: 6
Joined: Thu Jun 03, 2021 5:43 pm

Re: 2.5" TFT display no signal

by vulpinaut on Fri Jun 11, 2021 9:08 pm

Doesn't look like the new display has solved the issue. If anyone has any other troubleshooting steps they would be appreciated.

vulpinaut
 
Posts: 6
Joined: Thu Jun 03, 2021 5:43 pm

Re: 2.5" TFT display no signal

by adafruit_support_mike on Sat Jun 12, 2021 6:44 am

Find another NTSC/PAL video source and see if you can get output from that to show up on either display. The chance of two devices failing the same way is low.

adafruit_support_mike
 
Posts: 63052
Joined: Thu Feb 11, 2010 2:51 pm

Re: 2.5" TFT display no signal

by vulpinaut on Sat Jun 12, 2021 2:38 pm

The failure, as usual, was me. I couldn't find a pinout for this and it isn't labeled on the board and had assumed that the yellow input and the yellow output wire on the camera were the same, when in fact the yellow wire on the board is video ground. The WHITE wire on the board is input. It works now. Facepalm.

vulpinaut
 
Posts: 6
Joined: Thu Jun 03, 2021 5:43 pm

Re: 2.5" TFT display no signal

by adafruit_support_mike on Mon Jun 14, 2021 5:16 pm

Glad to hear you got it working. Happy hacking!

adafruit_support_mike
 
Posts: 63052
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.