0

16x32 RBG Matrix Spamming Incorrect PIxel Locations
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

16x32 RBG Matrix Spamming Incorrect PIxel Locations

by jakemadian on Sun Jun 13, 2021 1:06 pm

Hello!

I ordered a few 16x32 RGB matrix panels for a project I'm working on, but can't seem to even get 1 working with sample code.

I'm using a Raspberry Pi 4 Model B with HZeller's RGB LED Matrix Library, on top of recommended dietPI os.

When trying to run sample code for Demo 1
COMMAND: root@DietPi:~/rpi-rgb-led-matrix/examples-api-use# sudo ./demo -D 1 runtext.ppm

I should be seeing: http://youtu.be/OJvEWyvO4ro per his documents.

However I'm seeing: https://youtu.be/kUcjE8nM4_g

The colors seem to relatively match up but the pixel location seems very wrong.
Pictures of my setup are here: https://imgur.com/a/9RcAbEk

I've tried switching out as much as possible:
- 5V 10A power supply swapped for 5V 4A power supply.
-Confirmed board is getting 5V DC.
-Different power cables from matrix to bullet connector.
-Tried each of 3x RBG matrices, all exhibit identical behavior.
-Re-wiring and checking continuity to make sure no broken wires.
-Various demos in the git Library.
-Ribbon cable to M-F wire vs. F-F wire.

Any advice is appreciated.

jakemadian
 
Posts: 2
Joined: Sun Jun 13, 2021 1:53 am

Re: 16x32 RBG Matrix Spamming Incorrect PIxel Locations

by adafruit_support_carter on Tue Jun 15, 2021 1:31 pm

The jumper wire connection is very prone to having issues. We can't support troubleshooting it:
https://learn.adafruit.com/32x16-32x32- ... mper-wires

A matrix HAT or Bonnet makes things much easier and allows using the ribbon cable directly:
https://www.adafruit.com/product/2345
https://www.adafruit.com/product/3211

adafruit_support_carter
 
Posts: 20590
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.