0

NeoPixel Digital RGBW LED Strip Showing Incorrect Colors
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

NeoPixel Digital RGBW LED Strip Showing Incorrect Colors

by schofe on Wed Jun 16, 2021 12:29 pm

Order #: 2585465-2588372764
Product: NeoPixel Digital RGBW LED Strip 60 LED/m [ID:2837]
Purchased: 6/21

I am having trouble with a recently purchased LED strip. It powers up and accepts new programs but only 1/3 of the LEDs display correctly.
In the below pictures all pixels on the strip and board should be purple. Only every third LED seems to be working properly. So #1, #4, #7, #10 are correct and the do not change correctly. I have tried another strip and board and everything works fine. I am probably missing something incredibly obvious, so any help is appreciated.
Attachments
Screen Shot 2021-06-16 at 11.18.35 AM.png
LED strip
Screen Shot 2021-06-16 at 11.18.35 AM.png (730.57 KiB) Viewed 96 times
noePixel1.jpg
Board and connections
noePixel1.jpg (310.22 KiB) Viewed 96 times
Last edited by schofe on Wed Jun 16, 2021 1:14 pm, edited 1 time in total.

schofe
 
Posts: 2
Joined: Tue Jun 15, 2021 10:40 pm

Re: NeoPixel Digital RGBW LED Strip Showing Incorrect Colors

by franklin97355 on Wed Jun 16, 2021 12:32 pm

Make sure you are using the correct RGBW code. The strip takes 4 sets of data and the RGB code only sends 3.

franklin97355
 
Posts: 21964
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: NeoPixel Digital RGBW LED Strip Showing Incorrect Colors

by schofe on Wed Jun 16, 2021 1:14 pm

All solved, thank you for the help.

schofe
 
Posts: 2
Joined: Tue Jun 15, 2021 10:40 pm

Please be positive and constructive with your questions and comments.