Due to high demand expect some shipping delays at this time, orders may not ship for 1-2 business days.
0

64x32 RGB LED Matrix Not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

64x32 RGB LED Matrix Not working

by FifthCloud on Tue Sep 07, 2021 10:48 pm

Hello,

Have purchased the following components and have tried to configure them with no success.
    1 x 64x32 RGB LED Matrix - 3mm pitch[ID:2279]
    1 x 5V 4A (4000mA) switching power supply - UL Listed[ID:1466]
    1 x GPIO Ribbon Cable 2x8 IDC Cable - 16 pins 12" long[ID:4170] (I didn't realize that the matrix came with a ribbon cable so now I have an extra one)
    1 x Adafruit RGB Matrix Bonnet for Raspberry Pi[ID:3211]

Have configured them to both my Raspberry Pi Zero-W and my Raspberry Pi 4 (4GB model).

After running through the installation and turning all pixels on and to white I get the following images. Further, even running the demos I can see rows not turning on at all.

Looking elsewhere on this forum I can see that others have tried the following.
[list=]1. Checked cables
2. Plug in all the cables again
3. Verify soldering of pins for the Bonnet[/list]

Have gone through those items. As for the soldering it's possible that for my raspberry pi zero-w that I did not solder correctly thats why I have tried the bonnet plus matrix on my Raspberry Pi 4 as that came as a pre-soldered unit.

Still no success on getting this product to work correctly. Any suggestions?

FYI: if you're wondering why the bottom half of each image is showing yellow I have no clue. I updated one of the demos to turn every pixel to 255,255,255 (White).
Attachments
raspberry-pi-zero-w-all-white_copy.jpg
raspberry-pi-zero-w-all-white_copy.jpg (678.25 KiB) Viewed 115 times
raspberry-pi-4-all-white_copy.jpg
raspberry-pi-4-all-white_copy.jpg (771.17 KiB) Viewed 115 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by adafruit_support_carter on Wed Sep 08, 2021 1:36 pm

Can post a few more photos with ambient lighting showing all the connections on the back of the panel.

adafruit_support_carter
 
Posts: 21905
Joined: Tue Nov 29, 2016 2:45 pm

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Wed Sep 08, 2021 6:25 pm

Per your request I have attached pictures of the back of the matrix. Further, I have included pictures of the bonnet if you need that as well.
Attachments
bonnet_angle_1.jpg
bonnet_angle_1.jpg (598.7 KiB) Viewed 104 times
matrix_back_2.jpg
matrix_back_2.jpg (849.01 KiB) Viewed 104 times
matrix_back_1.jpg
matrix_back_1.jpg (821.64 KiB) Viewed 104 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by adafruit_support_carter on Thu Sep 09, 2021 12:29 pm

Thanks for the photos. That all looks fine.

Let's go back to the Pi4 again to rule out anything with the Pi Zero W header pin soldering.

Try the Pi4 setup again and try swapping the ribbon cable, since you bought a spare, and see if that changes anything.

Also, on the Pi4, you will likely need to add some slow down:
https://learn.adafruit.com/adafruit-rgb ... 2982010-30
For Raspberry Pi 3 use a slowdown of 1 to start (use higher values if image still flickers). For Raspberry Pi 4, use a slowdown of 4. Older Pi models might work with 0, try it.

adafruit_support_carter
 
Posts: 21905
Joined: Tue Nov 29, 2016 2:45 pm

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Sat Sep 11, 2021 6:28 pm

adafruit_support_carter wrote:Thanks for the photos. That all looks fine.

Let's go back to the Pi4 again to rule out anything with the Pi Zero W header pin soldering.

Try the Pi4 setup again and try swapping the ribbon cable, since you bought a spare, and see if that changes anything.

Also, on the Pi4, you will likely need to add some slow down:
https://learn.adafruit.com/adafruit-rgb ... 2982010-30
For Raspberry Pi 3 use a slowdown of 1 to start (use higher values if image still flickers). For Raspberry Pi 4, use a slowdown of 4. Older Pi models might work with 0, try it.



Here is all the pictures you have requested with the Raspberry Pi 4 and the extra ribbon cable. Also, the one with the matrix showing all the colors I ran the following demo and with all the options listed here: sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=0
Attachments
raspberry_pi_4_extra_ribbon.jpg
raspberry_pi_4_extra_ribbon.jpg (612.19 KiB) Viewed 95 times
raspberry_pi_4_extra_ribbon_slow_down_option.jpg
raspberry_pi_4_extra_ribbon_slow_down_option.jpg (690.39 KiB) Viewed 95 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Sat Sep 11, 2021 6:36 pm

One more thing I have forgotten to mention. If you're at Adafruit I wouldn't mind shipping the matrix to you so you can run all the tests you need/want. If you need a raspberry pi too to run some tests I can let you borrow mine.

Let me know. (Will pay for shipping. Sometimes I feel like a kid I want to "play/test" this product, but all I have been doing lately is veryfiying what's going on with this product.)

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by adafruit_support_carter on Tue Sep 14, 2021 1:20 pm

Thanks for the offer to return. But we typically just replace these once we can determine it's the actual matrix and not something else.

Did you try with non-zero slowdown values?
Code: Select all | TOGGLE FULL SIZE
sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=0

adafruit_support_carter
 
Posts: 21905
Joined: Tue Nov 29, 2016 2:45 pm

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Tue Sep 14, 2021 9:39 pm

adafruit_support_carter wrote:Thanks for the offer to return. But we typically just replace these once we can determine it's the actual matrix and not something else.

Did you try with non-zero slowdown values?
Code: Select all | TOGGLE FULL SIZE
sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=0


To answer your question yes I have and am still getting the same results.

I didn't mean "return" I meant if you want to continue diagnosising the issue I would be more than happy to ship the product to you so you can further your investigation. If you think it's fine I'll pay the shipping back. If there is indeed something wrong we can discuss options then.

What do you think?

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by adafruit_support_carter on Wed Sep 15, 2021 1:09 pm

In your photos above, it looks like the slow-down had an affect on the display. What was the highest value you tried?

Also, did you try swapping ribbon cables? No other changes, just re-run same command line example with both ribbon cables. No difference between ribbon cables?

adafruit_support_carter
 
Posts: 21905
Joined: Tue Nov 29, 2016 2:45 pm

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Thu Sep 16, 2021 8:41 pm

I re-ran all the tests using the Raspberry Pi 4. See attached images. Will post separately each image plus its command.

Gray Cable (The cable that came with Matrix)

sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=0
Attachments
raspberry_pi_4_gray_cable_gpio0.jpg
raspberry_pi_4_gray_cable_gpio0.jpg (831.44 KiB) Viewed 68 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Thu Sep 16, 2021 8:42 pm

Raspberry Pi 4. Gray Cable (The cable that came with Matrix)

sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=1
Attachments
raspberry_pi_4_gray_cable_gpio1.jpg
raspberry_pi_4_gray_cable_gpio1.jpg (798.42 KiB) Viewed 68 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Thu Sep 16, 2021 8:42 pm

Raspberry Pi 4. Gray Cable (The cable that came with Matrix)

sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=2
Attachments
raspberry_pi_4_gray_cable_gpio2.jpg
raspberry_pi_4_gray_cable_gpio2.jpg (851.17 KiB) Viewed 68 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Thu Sep 16, 2021 8:43 pm

Raspberry Pi 4. Gray Cable (The cable that came with Matrix)

sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=3
Attachments
raspberry_pi_4_gray_cable_gpio3.jpg
raspberry_pi_4_gray_cable_gpio3.jpg (905.32 KiB) Viewed 68 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Thu Sep 16, 2021 8:43 pm

Raspberry Pi 4. Gray Cable (The cable that came with Matrix)

sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=4
Attachments
raspberry_pi_4_gray_cable_gpio4.jpg
raspberry_pi_4_gray_cable_gpio4.jpg (949.47 KiB) Viewed 68 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Re: 64x32 RGB LED Matrix Not working

by FifthCloud on Thu Sep 16, 2021 8:44 pm

Raspberry Pi 4. Gray Cable (The cable that came with Matrix)

sudo ./demo -D3 --led-rows=32 --led-cols=64 --led-slowdown-gpio=5
Attachments
raspberry_pi_4_gray_cable_gpio5.jpg
raspberry_pi_4_gray_cable_gpio5.jpg (856.51 KiB) Viewed 68 times

FifthCloud
 
Posts: 22
Joined: Sat May 08, 2021 9:45 am

Please be positive and constructive with your questions and comments.