0

NeoPixel Stick Stuck on White
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: NeoPixel Stick Stuck on White

by jamesmcintoshjr on Fri Sep 26, 2014 8:45 pm

@electronicOz - I'm new to coding for these things, Thats code from the adafruit tutorial - https://learn.adafruit.com/3d-printed-c ... g/overview

@davidl13 - no because I don't actually have the part you're referring to, I was simply following along to a learning project on here, with the exact same parts. I WAS using a couple coin cells that were a bit high on voltage, but now that I received the lipo that was left out of my original shipment, which is 3.7v, I don't see why your technique should work, especially when I'm simply replicating the tutorial.

jamesmcintoshjr
 
Posts: 3
Joined: Mon Sep 22, 2014 9:47 am

Re: NeoPixel Stick Stuck on White

by davidl13 on Fri Sep 26, 2014 9:49 pm

jamesmcintoshjr
...especially when I'm simply replicating the tutorial.


Alright, then! I guess we're back to needing detailed pictures of your setup if you're still having problems.

davidl13
 
Posts: 186
Joined: Fri Oct 25, 2013 10:51 pm

Re: NeoPixel Stick Stuck on White

by ElectronicOz on Fri Sep 26, 2014 10:05 pm

Ok, sorry I didn't mean to sound like I was biting your head off.

That link is "nice" but where is the code? I too am new to this sort of thing and all the different sites are laid out - of course - differently!

P.S.

Although is it annoying: Could you try my bit of code and tell us what happens?

It isn't a FLASH thing, but more a TEST code.

ElectronicOz
 
Posts: 71
Joined: Fri Jun 20, 2014 7:13 pm

Re: NeoPixel Stick Stuck on White

by adafruit_support_bill on Sat Sep 27, 2014 5:49 am

That link is "nice" but where is the code? I too am new to this sort of thing and all the different sites are laid out - of course - differently!

For that tutorial, the code is on the "Circuit Diagram" page: https://learn.adafruit.com/3d-printed-c ... it-diagram
The loop is empty because the ring is lit up in setup() and never changes.

The fact that the ring lights up tends to indicate that the wiring is OK, but with the code you posted, you should be getting more of a teal/blue color. Please post photos of your build so we can take a look.

adafruit_support_bill
 
Posts: 66177
Joined: Sat Feb 07, 2009 10:11 am

Re: NeoPixel Stick Stuck on White

by YoungSoul on Thu Oct 23, 2014 10:36 pm

I know this thread is a little old, but it still helped me solve my 'white' neopixel problem. I am driving a 30 led/1 meter strand with a 5v trinket. I followed the Uber guide and put a 470 ohm resistor on the data line. But I always got an all white strand.

davidl13 said:
"From what I've seen, "whiteouts" are generally the result of a strip's (or ring's) Din peak voltage being too close to the strip's (or ring's) primary power voltage."

So I put a 10k resistor from the data line and it started to work. For any one else with a 'white out' condition, try to add a resistor greater than 470 ohm but less than 10k in series with the data output pin.

YoungSoul
 
Posts: 20
Joined: Mon Sep 01, 2014 2:34 pm

Re: NeoPixel Stick Stuck on White

by pburgess on Fri Oct 24, 2014 1:34 am

Another thing, if using a 16 MHz Trinket, be sure to include this line in setup():
Code: Select all | TOGGLE FULL SIZE
#if (F_CPU == 16000000L)
  clock_prescale_set(clock_div_1);
#endif

pburgess
 
Posts: 3928
Joined: Sun Oct 26, 2008 2:29 am

Re: NeoPixel Stick Stuck on White

by bradsilcox on Fri Sep 18, 2015 1:05 pm

I was working with the 5V Trinket and a 16 pixel ring and was having the same problem with the full white, the ring was actually heating up significantly after a few minutes or research. This thread saved my sketch with this line:
pburgess wrote:Another thing, if using a 16 MHz Trinket, be sure to include this line in setup():
Code: Select all | TOGGLE FULL SIZE
#if (F_CPU == 16000000L)
  clock_prescale_set(clock_div_1);
#endif

I'm not sure how I overlooked it when I was referencing the Kaleidoscope Eyes (Trinket-Powered NeoPixel LED Ring Goggles) project but glad I found my way here. If only I had more success flashing the Trinket from Linux but I guess that's why I keep a Windows box around still.

Brad

bradsilcox
 
Posts: 2
Joined: Wed Jun 03, 2009 11:18 pm

Re: NeoPixel Stick Stuck on White

by derrickschneider on Mon Aug 22, 2016 10:08 pm

Howdy all.

I'm running into a similar problem as above. I'm working on the Million-Color HSL Flashlight (http://makezine.com/projects/million-co ... lashlight/) and the system powers up, but my ring is all-white.

I've disconnected the signal wire from the Arduino to make sure that something wasn't sending signal, and, indeed, the lights don't light up. I've desoldered the wire that sits next to it based on the fear that I was shorting it. I've commented out all the code in the sketch and replaced it with setting the lights to mid-level green in the sketch.

I've double-checked the instructions and the connections and still it's all white.

Any thoughts?

derrickschneider
 
Posts: 1
Joined: Tue Aug 16, 2016 11:52 pm

Re: NeoPixel Stick Stuck on White

by marbaque on Fri Nov 03, 2017 6:56 pm

derrickschneider wrote:Howdy all.

I've double-checked the instructions and the connections and still it's all white.

Any thoughts?


Did you find any solution, I am having the same problem, using an arduino UNO with a pixel strip of 60 neopx.

marbaque
 
Posts: 3
Joined: Mon Jun 15, 2015 7:38 pm

Re: NeoPixel Stick Stuck on White

by Funman1 on Thu Apr 12, 2018 1:29 am

Just a heads up, I purchased some bare unsoldered units sold as "WS2812B's"
Soldered them to my PCB and had this exact same issue, Even with no MPU on the board yet, they all went FULL WHITE..
Even just applying 5V to a bare chip in my hand with some wires, again full white no data even connected.

Started "googling" and found this thread among others, BUT as it turns out apparently I was sold "SK6812" Which is a clone, and has slightly different behaviors (Like this).
They go full bright white as sort of a "test strip" function when they power on.

I installed my MPU and ran the usual code, and boom they all work just fine.
So not sure if Adafruit ever got a batch of these SK6812 MARKED as real WS2812B's and they made it into the wild, or what.
But just wanted to give a heads up to others that may run across this thread in a google search.
WATCH OUT for the knock off ones, they have a slightly different behavior.

If I had installed my MPU without testing my LEDs beforehand, I would have likely never have even known this was an issue.
Well I guess you may see this issue if you are waiting for a bootloader too, before the chip really kicks into code they would be white for a few seconds.

Anyways just a PSA....

Funman1
 
Posts: 371
Joined: Fri Nov 28, 2014 2:13 am

Re: NeoPixel Stick Stuck on White

by marbaque on Thu Apr 12, 2018 11:27 am

derrickschneider wrote:Howdy all.

I'm running into a similar problem as above. I'm working on the Million-Color HSL Flashlight (http://makezine.com/projects/million-co ... lashlight/) and the system powers up, but my ring is all-white.

I've disconnected the signal wire from the Arduino to make sure that something wasn't sending signal, and, indeed, the lights don't light up. I've desoldered the wire that sits next to it based on the fear that I was shorting it. I've commented out all the code in the sketch and replaced it with setting the lights to mid-level green in the sketch.

I've double-checked the instructions and the connections and still it's all white.

Any thoughts?


I had a similar problems where 1 meter of neopixels were lighting all white. After trying a lot I cut the first neopixel off the strip, wired it all again and it worked, seemed there was a problem (not sure exactly what kind of problem) with that first neopixel connection, but it worked after that.

Hope it helps.

marbaque
 
Posts: 3
Joined: Mon Jun 15, 2015 7:38 pm

Please be positive and constructive with your questions and comments.


cron